2
$\begingroup$

I'm using Blender to create a four-room Basement set for use in DAZ Studio. I have the basic architecture finished: floor, walls, ceiling, and stairwell. In DAZ Studio, I need to import this as a Figure with each object as a separate bone, so users can hide parts of the set while setting up scenes. Here is a screenshot of my Blender scene:

enter image description here

Alas, when I export this as an obj file and import it in DAZ Studio -- that is, adding the obj file as geometry to the DAZ Figure Setup window -- the set came in as a single object with no component parts that I could set as bones. How do I export an obj file with component parts that I can set as bones in DAZ Studio?

Thank you :-)

UPDATE: I realized that I had assigned each object to a group (in the Properties>Object panel) but not to a vertex group (in the Properties>Data panel). So I deleted the groups and assigned each object to its own vertex group. But when I exported as an obj and imported in DAZ Studio - again, adding geometry in the DAZ Figure Setup window - the entire set still came through as a single object with no component parts that I could set as bones.

UPDATE 2: The problem was my Blender export settings. A DAZ forum user suggested these settings -- where (+) means checked and (-) means unchecked -- and they worked:

Forward (Z Forward), Up (Y Up), Selection Only (-), Animation (-), Apply Modifiers (+), Include Edges (-), Smooth Groups (-), Bitflag Smooth Groups (-), Write Normals (-), Include UVs (+), Write Materials (+), Triangulate Faces (-), Write Nurbs (-), Polygroups (-), Objects as OBJ Objects (-), Objects as OBJ Groups (+), Material Groups (-), Keep Vertex Order (-), Scale (100.00), Path Mode (Auto).

$\endgroup$
  • $\begingroup$ I would have said to check the "Object as OBJ Objects" option, but glad it's working now. You should post the solution bellow as an answer for future reference instead $\endgroup$ – Duarte Farrajota Ramos Jun 25 '16 at 0:59
2
$\begingroup$

CORRECTED FIX: The problem was my Blender export settings. To ensure DAZ gets the normals correct on all faces, you need these settings: where (+) means checked and (-) means unchecked -- and they worked:

Forward (Z Forward), Up (Y Up), Selection Only (-), Animation (-), Apply Modifiers (+), Include Edges (+), Smooth Groups (-), Bitflag Smooth Groups (-), Write Normals (+), Include UVs (+), Write Materials (+), Triangulate Faces (-), Write Nurbs (-), Polygroups (-), Objects as OBJ Objects (-), Objects as OBJ Groups (+), Material Groups (-), Keep Vertex Order (-), Scale (100.00), Path Mode (Auto).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.