2
$\begingroup$

I'm trying to learn some basic modeling in blender, working on a long concrete hallway. there are supposed to be fluorescent lights on the ceiling of said hallway, and i made those out of emission+glossy shaders in the mesh itself. but this is resulting in an extremely noisy render, even at 1000+ samples.

I've tried changing clamp, filter glossy, caustics, nothing seems to be effective. might just be my pc, not sure.

here's the .blend file: https://mega.nz/#!LUdUGIaB!QFpdxi3DafcFbm5hpdU-qgo8K-LmMP5TZKD1lagCrK0

pc specs:

OS: windows 10 pro 64-bit

CPU: AMD Athlon II x4 640

Motherboard: MSI 870-G45

RAM:8GB

GPU: MSI NVIDIA GeForce GTX 650

render @ 128 samples: enter image description here

it might just be too dark i dunno

$\endgroup$
  • $\begingroup$ I suggest you remove the caustics (in the "light paths" section of the render panel). This is not a real solution as you will loose a bit of realism... but... $\endgroup$ – lemon Jun 23 '16 at 15:14
  • $\begingroup$ 128 samples is relatively low. Try 250 or more. It is also too dark. $\endgroup$ – Dontwalk Jun 23 '16 at 15:20
  • $\begingroup$ The image looks almost black on my phone, so I'd say you should try turning the lights up a bit. $\endgroup$ – Danial Dec 22 '16 at 4:52
  • 1
    $\begingroup$ using the emission shader as a light source instead of an actual lamp object always results in a VERY noisy scene. Always try to avoid it and use lamps. $\endgroup$ – Tooniis Jul 1 '17 at 14:16
1
$\begingroup$

this is a very complex topic and would be to much for a single post answer. but i am trying to give you a rough understanding about what you have to change:

In the virtual space, everything is about faking. not about recreating the real world. this means that it only has to look real from the field of view, but everything else does not matter.

This means: remove everything that does not matter. you do not need a complete interior, remove the all walls that are not visible to the eye. this way every sample that would bounce against the wall, now flies into infinity and does not produce more bounces (that would slow down your render).

also: do NEVER (if possible) light your scene whit mesh light. mesh light is way slower and produces much noise. again, just fake it! in the most cases nobody will notice that you only put a single spotlight there (make sure that multiple importance is activated in the lights material settings). the bigger the light source, the less noise.

also some technical stuff. set the render settings as followed: sampling: set "clamp direct" and "inderect" to 9. light paths: "filter glossy" to 0.5-2 (higher values mean less noise but more blury pictures).

|improve this answer|||||
$\endgroup$
0
$\begingroup$

Here are a few things that could help you...you will need to really ramp up your sample count though which will lead to MUCH longer render times.

A nice SE answer:

https://blender.stackexchange.com/a/18305/28015

This is a fairly simple article on the topic:

https://www.blenderguru.com/articles/7-ways-get-rid-fireflies/

Another option (that REALLY helps especially with animations) is to use baking. You can bake the lighting with an incredibly high sample count (10000 or something) overnight, then not worry about recalculating later. But that's a whole other topic...here is a nice quick start tutorial for baking in cycles:

https://www.blenderguru.com/tutorials/introduction-baking-cycles/

|improve this answer|||||
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.