5
$\begingroup$

I'm using Blender 2.69. I added a plane mesh to the model (display draw type: Texture). Added a material and a alpha transparent PNG image (coordinates is UV, rest is all default). In the UA/Image Editor I definitely see the transparency of the PNG file that I put on top of the plane/mesh. In the 3D View the image is displayed on the mesh. However, the color of the plane is black, albeit the preview of the material is showing transparent. Why is that?

For test purpose I also changed the material to transparent, alpha value 0.2. The plane remains black. Why is it that I'm missing out here?

Observation: In the Viewport Shading, "Rendered" would show the panel transparent. But not in "Textured" mode. I'm puzzled. Shouldn't "Textured" viewport shading show textures?!? Have I got the wronng expectation?

Renderer: Blender Renderer OS: Win 8.1

$\endgroup$
3
$\begingroup$

When using the blender internal render engine you need to use glsl shading to see transparency in textured mode. This option can be found in the properties panel on the right of the 3dview by pressing N.

enter image description here

When using the cycles render engine, the nodes based materials effect the 3dview when in rendered mode, while some nodes have a limited effect in textured mode.

$\endgroup$
  • $\begingroup$ I was able to create the above image (heart on top and bottom) using luxrender nodes. Mixed null and matte materials. Is there a way to actually connect the two hearts so it looks like there is a side to it too? $\endgroup$ – user2623 Feb 28 '14 at 2:26
  • $\begingroup$ Not without actually modeling it. $\endgroup$ – gandalf3 Feb 28 '14 at 2:34
  • $\begingroup$ @gandalf3 I have a question that I feel is a bit relevant to the questions and the answer here. I wonder could you please take a look at my question here? I basically want to render depth maps or surface Normals by somehow ignoring the transparent materials. Do you think that's possible? $\endgroup$ – Amir Feb 25 '18 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy