1
$\begingroup$

Hey I'm struggling with an obj File. I got an obj file and everything seems fine except the Textures are missing. I checked the .mtl file and the .obj file.

I've already looked at Importing OBJ with MTL and Image not working properly

In the .obj File at the start of the File it looks like this after I've replaced an absolute path in mtllib:

# FILE 11740_Baumgartu_Haus_0_3D-Export.obj
mtllib 11740_Baumgartu_Haus_0_3D-Export.mtl
trace_obj 11740_Baumgartu_Haus_0_3D-Export.obj
shadow_obj 11740_Baumgartu_Haus_0_3D-Export.obj

g C211_AUSSENWAND_TR VERPUTZ__GLATT__WEISS

usemtl VERPUTZ__GLATT__WEISS

v -24948.3 -6963.67 8330
v -24903.8 -7471.73 8330
v -24704.6 -7454.3 8330
v -24749 -6946.24 8330
v -25012.6 -7146.54 8570
v -25028 -6970.64 8570
...

and in the mtl file it looks like this:

# FILE:11740_Baumgartu_Haus_0_3D-Export.obj
newmtl VERPUTZ__GLATT__WEISS
Ka 0.916471 0.916471 0.916471
Kd 0.964706 0.964706 0.964706
Ks 0 0 0
illum 2
Ns 100
map_Ka verputz_glatt_weiss.jpg
map_Kd verputz_glatt_weiss.jpg
map_Ks verputz_glatt_weiss.jpg
newmtl 011740_FASSADE_FENSTERBAND
Ka 0.4 0.4 0.376471
Kd 0.633333 0.633333 0.596078
Ks 0.25 0.25 0.25
illum 2
Ns 5
...

The textures are placed in the Folder "11740_Baumgartu_Haus_0_3D-Export_Texturen" inside the Folder where the obj and mtl file is. I have copied the textures directly into the same folder as the mtl and obj aswell. Can't find what is still missing

In Blender it looks like this: missing texture

when importing I have set the search images checkbox

$\endgroup$
  • $\begingroup$ From your screen capture, it seems that the object is not selected/active (it is appearing in orange and not in yellow). Is it the same if it is the active object (RMB on it) ? $\endgroup$ – lemon Jun 22 '16 at 7:08
  • $\begingroup$ Yes I can select one of the objects and it's the same. If i enable Textures in the Viewport shader they are not applied. $\endgroup$ – TheCell Jun 22 '16 at 7:09
  • $\begingroup$ I think Blender may show the textures objects even if it is not able to find the textures files. So... if you dont have any textures objects in Blender, this is not a path problem, but a textures objects problem ? $\endgroup$ – lemon Jun 22 '16 at 7:15
  • $\begingroup$ Please, add a screen capture of the object textures once the object is selected as active, in order to see if the textures are defined on it (not the rendering, but the texture data in the texture panel) $\endgroup$ – lemon Jun 22 '16 at 7:18
  • $\begingroup$ i.imgur.com/2cubtKA.jpg $\endgroup$ – TheCell Jun 22 '16 at 8:07
0
$\begingroup$

Please check if the name in the code (mtllib Name.mtl) from the OBJ file is the same as the MTL file name.

If it's not please tweak the code or change the name of the MTL file. This issue happened to me too when i realised the OBJ file doesn't have the same name in the code.

If this doesn't work and/or the filename was the same then there is probably an issue with the code. If the code doesn't match the pictures name's then you schould modify the names.

~Randy

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.