1
$\begingroup$

First of all I want to specify my final goal: use the Solidify Modifier in order to create a cage.

I think that my workflow, used since now,

  • Duplicate my low poly

  • Alt + S with the new mesh (i.e. cage)

isn't the way to achieve the best result, because it creates too much distorsion and doesn't preserve the original shape of my low poly, in particular with hard surfaces' meshes.

Therefore I found the solidify modifier that works pretty well. There's only one problem that i will show you with an easy example:

1) This is my High Poly

enter image description here

2) This is my Low Poly

enter image description here

I duplicate my Low poly and then with my new mesh (cage) I apply the Solidify Modifier in order to cover my high poly. The problem is that the solidify modifier double the mesh. In the final result i have my low poly, high poly and the cage, with 2 "meshes" (not divided, they are still a unique mesh in the Outliner) one inside the other like in the image below.

enter image description here

How can i delete the inner mesh?

In a simple mesh could be easy, like this cube, but when i have complex artifacts?

$\endgroup$
3
$\begingroup$

Not sure if I understand correctly but I think you may be misunderstanding what the Solidify modifier does.

It creates thickness on an object by duplication it's faces and offsetting the by a specified distance along its normals. This makes it two sided, and creates a new set of faces virtually "duplicating" your object.

That being said you may use it for what you want by activating the options Fill Rim and Only Rim, that way only the distorted "cage" will be created, and no duplicates will be found.

Solidify Rim Only

Edit

See an example of an open area bellow where additional faces are created.

Have you tried the Smooth modifier instead? It wont create additional faces, and will have a similar offset effect, though it may cause some distortion in tighter corners.

Smooth Modifier

Edit 2

Apparently the user's problem was with selecting linked geometry in edit mode. You could apply the Solidify modifier with the Fill Rim option unchecked, and then enter edit mode and either hover one of the unwanted vertex and press L or select one of the unwanted vertex and press Ctrl + L to Select Linked

enter image description here

$\endgroup$
  • $\begingroup$ Already used this trick. The problem here is this: checking "Fill rim", it adds vertices to my cage (in blender there is written: "Create Edge loops"). I'm creating a complex mesh with multiple smoothign groups etc . . and i want to have the same amount of vertices for my low poy and the cage. I can't tick it $\endgroup$ – Fuboski Jun 21 '16 at 23:35
  • 1
    $\begingroup$ Have you tried after applying and entering edit mode pressing L to select linked geometry? They are one and the same object but should be two separate chunks of mesh altogether. $\endgroup$ – Duarte Farrajota Ramos Jun 22 '16 at 11:26
  • 1
    $\begingroup$ @Fuboski, +1 for what Duarte just said (but Ctrl+L) $\endgroup$ – lemon Jun 22 '16 at 11:43
  • 1
    $\begingroup$ @Fuboski or eventually "separate by loose parts" : select all in edit mode, then P $\endgroup$ – lemon Jun 22 '16 at 11:45
  • 1
    $\begingroup$ Answer above updated, and image added. $\endgroup$ – Duarte Farrajota Ramos Jun 22 '16 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.