0
$\begingroup$

I'm attempting to open a file on a Linux computer through file sharing. The file is stored on a Macbook Pro and both computers are running Blender 2.77. However, when I try to open the file on the Linux computer, I get an error of, "No Such File or Directory." I don't think this is a file permissions error as my permissions settings are set so that "Everyone" can read and write my file. What can I do to solve this?

$\endgroup$
  • $\begingroup$ Make sure there are no unicode or non ASCII characters in your file path. They may cause trouble some times. $\endgroup$ – Duarte Farrajota Ramos Jun 21 '16 at 11:26
  • $\begingroup$ My file is just called "tiger.blend". $\endgroup$ – kriskendall99 Jun 21 '16 at 16:08
  • $\begingroup$ Yes, but I meant the rest of the complete folder path until you reach the file itself. $\endgroup$ – Duarte Farrajota Ramos Jun 21 '16 at 18:15
  • $\begingroup$ I ran into this exact problem between a Windows machine and a Ubuntu machine. My solution was Dropbox ;-) $\endgroup$ – Matt Jun 21 '16 at 20:29
  • $\begingroup$ Dropbox might work. I'll give that a shot. $\endgroup$ – kriskendall99 Jun 21 '16 at 20:48
1
$\begingroup$

No such file or directory" is somewhat common when

  • the file needs something else to be processed by the software you are working with (missing shared library for blender, missing linked file with textures, materials...)
  • the file doesn't exist (or at least it doesn't exist in the given directory)
  • the filename or the path consists of characters that cannot be read by linux

I assume that you have already used blender on linux successfully (eg opened a local file), so the first point is not the cause of the problem.

Permissions between operating systems are not as easy as it sounds. Both Apple and Windows tend to use some "magic" in their approaches of an easy-sounding task. So it's good to verify the permissions on OS level.

Try the following: Navigate to the tiger.blend file by using either the file browser (dolphin for KDE, Nautilus for GNOME, for Ubuntu whatever they are using) or the command line and try to rename the file into tiger1.blend. If you are able to successfully rename the file then there are no permission problems on the OS level.

Last but not least Blender does not necessarily use all of the Desktop Environment's file selection methods. While KDE's dolphin is capable of browsing paths with blanks (something like //Macbook/Awesome Blender Files/tiger.blend) other file managers might not. Blender seems to process blanks in paths correctly on SMB (samba) and CIFS (common internet file system) shares but I've never tried using Mac OS as a host system. Try to use simple paths without blanks, accents, umlauts, special characters...

$\endgroup$
  • $\begingroup$ The rename was successful. I checked that it worked by making sure the filename updated on the Mac, so it's not a permissions error. Maybe it is that the shared library is missing. Could it have something to do with the fact that Blender is being opened from my Downloads folder instead of the folder where other applications are kept? $\endgroup$ – kriskendall99 Jun 21 '16 at 18:06
  • $\begingroup$ @kriskendall99, not necessarily. Since most Linux distributions aren't up to date to the point when new blender versions arrive, I simply download the binaries from blender.org and extract them into my /home/username/bin folder. If you start blender from your Download directory and it shows the default cube, everything is fine. Oh, btw. check if your tiger.blend has linked textures or materials from other non-shared folders. $\endgroup$ – metaphor_set Jun 21 '16 at 18:48
  • $\begingroup$ I checked. Everything I'm using has been packed except for a video file. Could that be causing the problem? $\endgroup$ – kriskendall99 Jun 21 '16 at 20:57
  • $\begingroup$ Maybe you could copy all of the necessary files to your Linux machine and try if the error still appears if you open the file locally. $\endgroup$ – metaphor_set Jun 23 '16 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.