0
$\begingroup$

I am using a mirror modifier for modelling. When viewing the mesh in edit mode, the vertices in the center are firmly stuck together and cannot be separated.

enter image description here

When in pose mode, I manipulate a wrist bone on my model and the mesh splits in two along the mirror axis center.

enter image description here

I have tried removing the subsurface modifier to see if this was the problem leaving only the armature at the top of the modifier list,i.e. as first modifier (which I am told is the bottom of the stack) and the mirror as the second.

It doesn't separate in edit mode and I've also tried increasing the merge limit to 0.1 and there's no change. Manipulating bones separates the mesh.

$\endgroup$
  • $\begingroup$ try to place your mirror modifier before the armature modifier $\endgroup$ – lemon Jun 18 '16 at 16:27
  • $\begingroup$ Is "Clipping" in the Mirror Modifier enabled? It should be $\endgroup$ – WhovianBron3 Jun 18 '16 at 16:49
  • $\begingroup$ @user3168961, please consider to give the answer to your own question $\endgroup$ – lemon Jun 18 '16 at 18:30
1
$\begingroup$

Finally it was the order of the modifiers.

Positioning the mirror modifier before the armature modifier in the modifier stack fixed the issue.

The problem seemed to be that the bone transforms made in pose mode were applied first and then after the mirror was applied, which caused the splitting.

$\endgroup$
  • $\begingroup$ Yeah, for modifier evaluation the top modifer gets applied first, all the way down to the bottom one last. $\endgroup$ – Sazerac Jun 20 '16 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.