0
$\begingroup$

I created a text object and then converted it to Mesh (Alt+C).

What I want to do? Achieve a fade-in animation. Insert one keyframe for transparency when it is fully transparent, and another when the object's opaque.

What's the problem?

I am stuck at the first step. I can't seem to make it transparent. Here's a screenshot:

enter image description here

The transparency works in the solid view but not in rendered mode. If it matters, I have some keyframes related to scale attached to that mesh text object.

I had followed one tutorial that led to me the above step. I have also seen this question Alpha transparency not working but it did not work for me.

Question:

Why is my method not working?

$\endgroup$
  • 1
    $\begingroup$ It works in viewport because you adjusted alpha transparence only for viewport (Material > Settings > Viewport Color ); for rendering shader should be present $\endgroup$ – Mr Zak Jun 18 '16 at 8:22
  • $\begingroup$ @MrZak Oh, it was a silly mistake! :P $\endgroup$ – Gaurang Tandon Jun 18 '16 at 8:57
2
$\begingroup$

To render transparency in Cycles you need a transparency shader.

Setup your nodes in this kind of configuration, and set your key frames on the "Fac" value of the "Mix Shader" :

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.