1
$\begingroup$

Partial transparency with node editor ignores other objects behind (draws world background) asked here for consequences that came up after solving this problem.

-------------

I so far found a question which has been answered but the answer doesn't help me with my problem. (See this here: UV Map not being applied to object)
I have got an object that shall be acting as a low-poly solution for a horse mane. Thanks to someone who replied to an other question, I figured out how to get the object being transparent, following the alpha of the texture.
But when I do that, the UV settings dissapear from the texture/material tab. I cannot use cycles render, my computer is too slow.

Is there a way to keep the UV mapping and make the texture be transparent where its alpha value is (nearly) 0?

If anyone knows how to fix this, or has got even a hint, I'd be happy for any reply.

Edit 1: I used this reply for changing the object settings: Blender Cloud texture settings: How to get from 0 alpha partial transparency in render?

This is how it appears when I activate the nodes to make the edges transparent; the UV mapping got messed up and the UV-mapping option is not aviable in the apropriate tab.

Wrong mapped texture

When I deactivate them it looks like this: Mane without nodes
However, the object isn't transparent and somehow (what I didn't expect) the color turned black though it was a light grey.


Both screenshots were taken from rendered 3D view (so no real render just preview)


--

Edit 2: After changing the nodes as visible in the following screenshot, the UV map turned mapped right.
Still, the transparency value is a bit too strong. After I made the horse mesh visible, I found a second error. The mesh is now transparent, but it is displaying the world background instead of the model laying underneath. I am going to do a testrender to see if that happens in render output too or just the 3D-View that trolls me here.

Transparency ignoring mesh underneath


Thanks everyone for trying to help me so far. I have to admit that I'm pretty new to nodes editor, but I hope to gain some experience with it and being able to cope with problems without need to ask about everything^^

$\endgroup$
  • $\begingroup$ Transparency has nothing to do with UV maping, they are two completely separate settings of a material/texture. How are you doing this? Could you post more info about your file, maybe some screenshots of the problem, or perhaps a link to the file? $\endgroup$ – Duarte Farrajota Ramos Jun 18 '16 at 22:59
  • $\begingroup$ I know that they are two different things, but somehow they turned messed up that way. File is very big and it would take a lot of time to just take the single object. I attached some screenshots, hope this helps a bit. $\endgroup$ – xDonnervogelx Jun 19 '16 at 16:07
1
$\begingroup$

You clipped your first screenshot right where it mattered , seeing your complete node setup would help solve the issue.

Are there any more nodes in your material? Is there anything connected to the Vector socket of your image texture?

If not that is where your problem is. When using node materials and textures you must specify which type of texture coordinates to use in your texture within the node setup, to correctly display it.

Before your image texture node add a new Input > Geometry node, choose one set of UV Coordinates from the pull-down menu and connect the UV socket to the vector input of the image node.

$\endgroup$
  • $\begingroup$ Okay thank you, that solved the messed up UV coordinates. It still looks very transparent, though it should only be where there are the big gaps in between and at the end. I'm very new to nodes editor, I hope it's okay to ask here instead of putting a new question since it's that much related to the issue I had before. $\endgroup$ – xDonnervogelx Jun 20 '16 at 9:50
  • $\begingroup$ It's probably best to place a new question if it's a different issue, especially since it's likely worth posting new images to illustrate the problem. Also to get attention from other users, I probably won't have time to look into it until later today. $\endgroup$ – Duarte Farrajota Ramos Jun 20 '16 at 9:55
  • $\begingroup$ Okay I'll do that tomorrow then; I sadly have no time today either. So I don't mind if it takes time for a next reply. If you know something about it, then feel free to answer however, I will link both questions as soon as I posted the new one (if it's necessary to do a new one when I return to look here tomorrow). $\endgroup$ – xDonnervogelx Jun 20 '16 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.