24
$\begingroup$

I have created this sign, but when I added the red texture to the face, the texture turned out sideways. Is there a way to rotate it? The original image is the right way up.

Rotated stop sign

In the texture settings there doesn't seem to be a rotation value. Texture settings

$\endgroup$

4 Answers 4

16
$\begingroup$

The way of doing it with simple (non-UV) texture mapping, is to tweak the mapping coordinate and scale.

1a

For example:

  • Switching X and Y axis, and scaling X by -1 will rotate the texture 90 degrees clockwise.
  • Switching X and Y axis, and scaling Y by -1 will rotate the texture 90 degrees counter-clockwise.
  • Scaling X and Y by -1 will flip the image vertically.

But you see that it's quite limiting, less intuitive and flexible than UV-map based rotation, described in gandalf3's answer.

$\endgroup$
17
$\begingroup$

You need to UV unwrap it:

  1. Enter edit mode and select all (A)

  2. Unwrap the mesh. For that flat plane the best way is probably aligning your view to the face of the sign (shiftNumpad 7 with the face selected) and pressing U> Project from view.

  3. Then select the UV coordinates in Texture > Mapping:

    enter image description here

You should be able to rotate the UV map in the UV image editor with R to adjust the rotation.

See the wiki for more information.

Cycles:

Note that in cycles it's possible to rotate the texture without UV unwrapping via the Mapping node:

enter image description here

$\endgroup$
2
  • $\begingroup$ The texture was applied with a material the doesn't seem to be any setting for rotation $\endgroup$
    – Qwertie
    Commented Dec 17, 2013 at 6:56
  • $\begingroup$ @qwertie In that case you haven't unwrapped your sign yet. There is a way to rotate it, (I'll update my answer) but I recommend UV unwrapping it (see the wiki). $\endgroup$
    – gandalf3
    Commented Dec 17, 2013 at 6:57
3
$\begingroup$

Image Sampling > Flip X/Y Axis

image sampling > flip x/y axis

$\endgroup$
3
  • 1
    $\begingroup$ Need more context. Where is this in the UI? $\endgroup$ Commented Feb 28, 2018 at 16:28
  • 2
    $\begingroup$ @foobarbecue it's an old answer so probably this feature may have been removed with cycles, but on Blender Render the panel is located typically on the right "Properties/Texture" panel with "Type" set to "Image or Movie"... the fix in Cycles is to adjust the "Scale" to "-1" $\endgroup$
    – Eli Peters
    Commented Mar 2, 2018 at 4:05
  • $\begingroup$ Using a mapping node and adjusting the scale to -1 as Eli stated works perfect, just be sure the image node is set to "Repeat" and not "Clip". Otherwise, a negative scale produces a black output. $\endgroup$
    – scottywood
    Commented Nov 20, 2019 at 19:31
0
$\begingroup$

Make sure to use the UV output of the Texture Coordinate node.

Make sure to use the UV output in the texture coordinate node

$\endgroup$
1
  • $\begingroup$ Not necessarily; the OP might not have created a UV map. $\endgroup$
    – Joachim
    Commented May 30 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .