2
$\begingroup$

After modifying an object I deleted the camera, and after that I add a new camera to the scene but in the end I couldn't see anything with my new camera view with Numpad 0 and rendering, it just shows blank.

Can anyone help me? Thank you.

Blender File

$\endgroup$
  • $\begingroup$ That file is corrupted $\endgroup$ – someonewithpc Jun 16 '16 at 12:07
8
$\begingroup$

That's because the scene camera was set to the mesh itself, instead of the Camera:

enter image description here

Just imagine: Can you see your own face without a mirror in real world? :P

Solution is simple: Go to Scene tab (located in Property Editor), use the actual camera object instead of the default one. Or select the camera object then press Ctrl Numpad 0 to set it as the active Camera to the scene.

Another issue in this case is that the Aperture type of the camera was set to Radius, which makes everything blurry with current parameters. Or you can simply switch to F-Stop to solve the blank render issue:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ HEii.. it WORKS ... thankyou LEon cheung for the help, And the next problem is .. my rendered still black, LOL can you help me ? $\endgroup$ – rieza numan Jun 17 '16 at 6:31
  • $\begingroup$ OK, I think I found another why. See updated answer. :) $\endgroup$ – Leon Cheung Jun 17 '16 at 7:26
  • $\begingroup$ Wowww .. amazing, thank you Leon, It works :) $\endgroup$ – rieza numan Jun 17 '16 at 9:09
  • $\begingroup$ Vote? for sure.. how to vote? $\endgroup$ – rieza numan Jun 17 '16 at 12:03
1
$\begingroup$

Not sure what is wrong exactly with your file, some sort of glitch.

I created a new camera object, switched to it as active camera with Ctrl + 0, then switched back to your originally created camera and it started displaying correctly again.

Make sure you clear your camera objects scale with Alt + S and make sure you adjuts the clipping limits so your objects are within the visible area.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thankyou for Helping me ... Now I can see through my camera but my render still blank .. $\endgroup$ – rieza numan Jun 17 '16 at 7:25
0
$\begingroup$

Focus Distance must not equal 0

In my case, the problem was that "Distance" was set to 0. Perhaps the object it was supposed to focus on was deleted at some point without me noticing.

Set a Focus object or set a manual value greater than 0.

Camera settings

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.