1
$\begingroup$

This has probably been asked and answered elsewhere, but I can't find it, so....

I designed a simple animated logo in Blender, with a spinning earth between two light-emitting text objects, with two point lamps for extra light. I rendered and saved the animation, and then used a gif conversion utility to save it as a gif. That all worked fine, but ...

... I decided I wasn't satisfied with the lighting. So I did Save As to start a new file, deleted the two point lamps from my original file, then added two Sun lamps (a Sun emitting a golden color from the left, a Moon emitting a pale blue from the right) and two dim Hemi lamps for high- and low-fill.

But when I Render I still get my original lighting. Similarly, if I Render Animation, I still get the original lighting.

How do I refresh the render process so I can see my new lighting?

Here is the Blender file:

UPDATE: Simply, it's not performing new renders. I deleted all of the original render frames, then clicked Render ... and I get a blank screen, because render image it had been displaying is no longer there.

UPDATE2: I went back and reopened the original file, from which I did a Save-As to create this new file ... and the original will not perform a new render either.

If I click the Render button, I get a blank screen, because the previous render (that it had been displaying) has been deleted.

Again, this is not about what I see in my 3D View. I see my lighting changes there. But I can't render a new image, or a new animation, at all.

UPDATE3: The solution was, per the answer below, to turn off Sequencing and Compositing in Properties > Render > Post Processing.

The relighted animation starts with this frame:

Frame 1

In the 180th frame, the earth has almost completed one rotation:

Frame 180

The lighting looks as I'd hoped: warm sunlight from direct left and cool moonlight from direct right, with dim neutral lights along the centerline to mute what would otherwise be a deep shadow at the sunset-moonrise horizon.

In clock terms, it's 12:00 noon on the left rim of the earth, and 12:00 midnight on the right rim. In terms of physics, my moonlight is far too bright; it's 1/2 the intensity of the sunlight, whereas in reality the ratio is about 1:400,000. But with the cooler color, it gives the effect I wanted.

$\endgroup$
0
$\begingroup$

You don't need to refresh anything, lighting is always up to date and recalculated per render, unless you somehow baked it into the objects.

How are you rendering this, using Cycles? Could you post some screenshots or perhaps a blender file?

Hemi lights are not supported in Cycles, they will render as point lights as stated in the Blender Manual, and in most situations you will want only one sun light in your scene, so perhaps use some area lights instead, and use the world background for ambient light.

Edit

You scene is updating real time as expected, see bellow.

Lighting update

Deleting lights updates the scene immediately

Some random tips

Hemi lights are like ambient lights, they emit light from a 180º dome, you generally do not want many of them in your scene. Many will cause a washed out and bland lighting that will absorb details.

Also sun lights are generally used sparingly in most scenes because they emit parallel rays of light. Try using a mix of spot lights, point lights and area lamps instead.

Edit II Disable Compositing and Sequencer in the Properties Window > Render > Post Processing

$\endgroup$
  • $\begingroup$ I added the Blender file above. I don't remember baking anything. But I even tried restarting my computer, and it still renders with the original lighting. None of the new lights has any effect. It's as if that image is cached somehow. $\endgroup$ – Crissie Brown Jun 16 '16 at 12:50
  • $\begingroup$ Updated answer above $\endgroup$ – Duarte Farrajota Ramos Jun 16 '16 at 13:05
  • $\begingroup$ Yes, it updates in the 3D View. But I can't render it. Clicking the Render button simply tries to reload a previous rendered image (that I've since deleted.) See my update above. As for trying a different lighting mix, I can't see what my current mix produces, let alone know whether I want to change it ... because I can't render a new image. $\endgroup$ – Crissie Brown Jun 16 '16 at 13:08
  • $\begingroup$ Disable Compositing and Sequencer in the rendering panel, answer above updated $\endgroup$ – Duarte Farrajota Ramos Jun 16 '16 at 13:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.