0
$\begingroup$

I have a render in cycles that I want to use as a still shot but I'm having trouble with compositing layers. I have three separate layers all showing different objects, but when I use an alpha over node only one layer shows up

in-case this is a simple problem I'll keep this post short, but if anyone need's SS then I can provide them

thanks

Link to Blend File: http://puu.sh/pvqXT/3fe1d73a82.zip

$\endgroup$
  • $\begingroup$ Are you sure you turned on the 'Transparent' checkbox on 'Film' section on 'Render' property button? Otherwise the layers won't be rendered with transparent background. $\endgroup$ – drmad Jun 16 '16 at 5:35
  • $\begingroup$ please add more information. edit your question and add images of your current setup so that we can understand better what the issue is. Please clarify: Do the layers have an alpha channel? Is film transparent enabled in the properties window? Please help us understand what the elements are so that we can help you better. Post your compositing nodes and any information that could be relevant. To get better answers don't wait to be asked for information. $\endgroup$ – cegaton Jun 16 '16 at 7:07
  • $\begingroup$ sorry I was afk for a while, link to the blend file is now available, any help would be immensely appreciated $\endgroup$ – John Jun 17 '16 at 0:22
0
$\begingroup$

Your image renders properly when you select "Transparent' within the Cycles 'Film' section.... In the Blender file available for download, it is unchecked...

When checked, this is the result I get... and nice sparks!

enter image description here

Sorry... was not sure if it was in or out.... Is this as you intended? See Gears6 blend file... if this is correct, the issue was in the node tree.... but, if not, I misunderstood. :)

enter image description here

$\endgroup$
  • $\begingroup$ unfortunately that doesn't solve my issue , since at the end of the cord there was a globe being lit. I tried ticking transparent as well but it doesn't show the light bulb. You'll find it in one of the render layers along with the compositor nodes to make it glow $\endgroup$ – John Jun 17 '16 at 8:53
  • $\begingroup$ Hope you saw my new file.... does that address it? $\endgroup$ – rcgauer Jun 18 '16 at 19:47
  • $\begingroup$ Sorry I didn't have the chance to check it out until now. It works perfectly thank you so much :D $\endgroup$ – John Jun 19 '16 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.