1
$\begingroup$

I have a simple sphere with a hair particle system on it. When I add hair dynamics, the hair simply falls through the mesh.

I would like the hair to fall around the mesh and collide with it (both the emitter object and other objects). I have read many other posts about how to get the hair from falling through the mesh, but all of them simply suggest turning on collision on the mesh ... which I have tried to do.

enter image description here

I am new to blender, so I am sure I am missing something obvious.

$\endgroup$
  • $\begingroup$ Possibly of help: How do I make hair collide with a mesh? $\endgroup$ – David Jun 16 '16 at 1:56
  • $\begingroup$ Thanks for the link, David. I have looked at that post and tried my best to follow the advice, but to no avail. The link you suggested is in relation to making the hair collide with a soft body object and I've tried changing my mesh to a soft body to more specifically follow the outline of the answers ... still no luck. I've included the blender file I'm working with in the question if that helps. $\endgroup$ – CurtisF Jun 16 '16 at 4:10
2
$\begingroup$

Enabling collision on the emitter doesn't work on the hair system, yet (2.77). To achieve collision, you have to do a workaround with a collision mesh: 1. You have to duplicate your model. 2. remove the hair particle system on the duplicated Mesh. 3. Exclude the duplicated mesh from rendering (uncheck rendering in the outliner). 4. Enable collision on the duplicated mesh.

You may need to tweak the settings a bit though.

$\endgroup$
  • 3
    $\begingroup$ This is a good answer, but needs to be a bit more complete. Keep in mind that this is not a forum. Think of it more like you're writing a Wiki article. Your answer should be useful to someone else who is having the same problem. $\endgroup$ – Matt Jun 22 '16 at 17:53
  • $\begingroup$ Good to know that emitter collision is not a feature yet. Couldn't quite get your work around to function the way I want (i.e. turn stiffness down and the hair still goes through the mesh), but maybe the other settings mentioned in your last line would help ... any setting in particular? $\endgroup$ – CurtisF Jun 24 '16 at 3:39
  • $\begingroup$ Marking this as the correct answer because anything requiring a decent amount of physics doesn't work very well with a hair system (first sentence). I will likely re-implement with polygon hair to get better collision options. $\endgroup$ – CurtisF Jun 24 '16 at 4:02
  • $\begingroup$ blender.stackexchange.com/a/62133/1322 is a pretty good answer to a similar question. $\endgroup$ – Samuli Kärkkäinen Aug 30 '17 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.