0
$\begingroup$

I have a custom made object (no simple standard mesh, but nothing complex, see below) and lost a lot of time trying to make the edges smooth. I tried the bevel modifier, sub surf modifier and bevel by select certain edges (ctrl+B). None of them worked fast and reliable.

  • Selecting them edge by edge (very time consuming) left me with problems where two different bevels where meeting.
  • the bevel modifier did no work as expected every time
  • sub surf modifier just created a very distorted mesh.

This is my mesh (viewed from different angles):

enter image description here

enter image description here

enter image description here

I just want all the edges to be smooth. No big deal...I thought :) I only succeeded on the front ones.

$\endgroup$
5
  • $\begingroup$ Did you enable smooth in shading? $\endgroup$
    – Georges D
    Jun 15, 2016 at 15:36
  • $\begingroup$ I need this as a real object afterwards so shading does not help me. At least as I understand it. Thanks $\endgroup$
    – digit
    Jun 15, 2016 at 15:42
  • $\begingroup$ @user413734, do you want to 3D print it ? $\endgroup$
    – lemon
    Jun 15, 2016 at 15:52
  • $\begingroup$ Yes, I just need these edges to be smooth and the rest of the object not distorted. $\endgroup$
    – digit
    Jun 15, 2016 at 15:55
  • 1
    $\begingroup$ Try using Bevel modifier with angles enabled as a limit, then apply the subdivision surface modifier $\endgroup$
    – Georges D
    Jun 15, 2016 at 16:11

1 Answer 1

1
$\begingroup$

The point is to imagine the several angles your mesh will have to be bent.

It can be composed of an initial shape and 3 modifiers : mirror, simple deform and subsurface.

enter image description here Here, there is a final curve : the "U" general shape.

But before that the mesh can be flat. Here the mesh before using the two final modifier (simple deform and subsurface) :

enter image description here

The main point is to use quad everywhere so that :

  • Edges are in the good position to be bend to the "U"
  • Subsurface modifier works well

Notice the selected line on the screen capture : it is here to preserve the outer edge and avoid the subsurf to deform it too much.

As you want to print it, you may want a "lot" of subdivision.

Here is the modifiers stack :

enter image description here

Here is the blend file

$\endgroup$
4
  • $\begingroup$ I can't reproduce it. Can you share the blend ? What is the starting form you used ? A cube with rounded corners ? Did you choose a Mirror Object in the Mirror Modifier. Thanks. $\endgroup$
    – digit
    Jun 16, 2016 at 12:37
  • $\begingroup$ Edited to add the file (at the end of the post) $\endgroup$
    – lemon
    Jun 16, 2016 at 12:47
  • $\begingroup$ Thank you very much. One last questions how did you add the line that protects the edge. Edge Loops won't work with me becuase it is not a straight line I think. Thanks again. $\endgroup$
    – digit
    Jun 17, 2016 at 7:56
  • $\begingroup$ @user413734, if I remember well, a bevel, Ctrl+B and the some manual adjustments for the extremities $\endgroup$
    – lemon
    Jun 17, 2016 at 8:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .