0
$\begingroup$

I'm having a bit of an issue with my model when subdividing it. I am very new to blender and 3D modelling and have just been trying out various things to achieve what I want but this is something I can't quite solve.

When I have subdivide set to 0, the UV map projects fine but as soon as I increase my sub divide, the checkered texture starts to show. Can someone help me with this or point me in the right direction to solve this issue?

Without Subdivide With Subdivide

$\endgroup$
  • $\begingroup$ in the modifier enable subdivide uvs and see if it help a bit , also try recalculating the normals with Ctrl+N. $\endgroup$ – user2816 Jun 15 '16 at 5:48
1
$\begingroup$

The issue was having multiple textures for the UV Map. It was loading the checkered texture for some sections when I subdivided which was weird. I simply selected all faces, changes the image to the checkered texture and then back again and it seemed to fix the issue.

$\endgroup$
0
$\begingroup$

On the subdivision modifier there should be a subdivide uvs option that you can uncheck. If this is unchecked the UVs will effectively be projected prior to subdivision. This means you won't see the checkered pattern creeping in around the seams, but you will instead see warping of the texture around the UVs as the subdivision will check the ratio between faces. (see https://www.blender.org/manual/modeling/modifiers/generate/subsurf.html)

If you know what subdivision level you need to end result to be, you can instead paint textures to the mesh at that subdivision level.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.