3
$\begingroup$

In the viewport, smoke looks fine:

Smokey cube in the viewport

However, when I render it with the OpenGL render:

Smokey cube rendered with OpenGL

It looks white because of the background; it's really transparent.

What causes this?

$\endgroup$
2
$\begingroup$

I would consider that a bug.

It appears that when the smoke flow object is set to Fire or Fire+Smoke it renders transparent with opengl render.

The fire simulator uses it's own material settings to preview in the 3dview - not the material settings that we configure. It would appear that this preview material works in the 3dview but not the opengl render.

$\endgroup$
2
  • $\begingroup$ Reported $\endgroup$ – gandalf3 Dec 16 '13 at 20:06
  • $\begingroup$ For reference this is fixed in source builds after 18 Dec 2013 - will be in release 2.70 $\endgroup$ – sambler Dec 20 '13 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.