0
$\begingroup$

I was trying to simulate an animation of fluid flowing from one cup to another, but after baking the domain, there is this strange shape that stretch all the way out of the cup, and I wasn't sure what had caused it.

Tried turning up the resolution but the domain still stretched far off the cup into a line or something. Please help?

Screenshots:

The strange looking domain (stretching outside of cup) after baking

My domain settings

Thanks :)

$\endgroup$
2
  • $\begingroup$ Could you share the blend file or Part of it? $\endgroup$ – user24962 Jun 12 '16 at 12:33
  • $\begingroup$ @BlenderPony When asking people to share a blend it's best to suggest where to upload it, e.g. here: blend-exchange.giantcowfilms.com $\endgroup$ – Ray Mairlot Jun 12 '16 at 13:29
0
$\begingroup$

Have you tried the following things:

-Change the volume initialization's volume/shell/both settings on the obstacles the fluid interacts with, and seeing how they interact in a scene?

-Checked where the normals are set for objects, especially obstacles, to make sure they aren't projecting weird spaces into the domain?

-Looked at the initial trajectory of the inflow object?

I had similar issues with the fluid sim acting up (found here - Fluid sim is not working right; water forms a flat table with an object, creates a large gap ). The issues were a combination of objects needing their volume init changed, and the re-setting the normals to be inside. Took about an hour of debugging, but since it was my first fluid sim it taught me a lot about how tempermental the fluid sim calculations can be. The fluid sim is certainly a cross between "art" and "science", and you'll need some experimentation to understand how it operates. There's no easy fix, it just takes practice and time.

As I said though, if you can't figure it out after an hour or so, post back. It should be resolved with a bit of parameter spelunking though.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.