3
$\begingroup$

There are often times when I install an addon (place the file/folder into my blender/2.XX/scripts/addons folder) and then it simply does not show up in the addons list within blender, so cannot be activated. Installing it from a file places it in the blender scripts folder in my app data folder (windows 7), but they still don't show up. These are addons that I know work for others, as I see them install them in tutorial videos or the like (.py, not patches or anything.)

So far, I have checked to make sure I am not filtering them out with the Support level filters.

What causes an addon to not be seen by the program, and what further troubleshooting steps I can take to get these working?

$\endgroup$
  • 4
    $\begingroup$ I don't agree with the reason for the close vote. The question is similar enough to existing ones. (related: blender.stackexchange.com/questions/36160/…). A few things would help answer the question. 1) Which add-on (it helps to ask about a specific scenario, even if the answer can be generalized) 2) Do you have any messages about the addon if you start Blender from a commandline 3) Are you filtering with the correct Supported Level (there are three options just below the search feature on the Add-ons tab -- Official/Community/Testing) $\endgroup$ – zeffii Jun 12 '16 at 8:32
  • $\begingroup$ It's one addon at the moment, but I've had this with several overall. I'm looking for a generalized list, not specifics for a given addon (as is the case for the linked question.) I have updated the question to clarify that I have checked my Supported level filters. I haven't tried running blender from a command line (It seems i need python installed? Not clear.) Is there another way to check for addon errors? $\endgroup$ – Ascalon Jun 13 '16 at 4:13
  • $\begingroup$ Here is the addon in question though: github.com/cheece/JiggleArmature $\endgroup$ – Ascalon Jun 13 '16 at 5:01
  • 1
    $\begingroup$ also related: blender.stackexchange.com/questions/39745/… $\endgroup$ – zeffii Jun 13 '16 at 7:41
  • 1
    $\begingroup$ @zeffi picked it, it fails if you download the zip and tell blender to add the zip. unzip it and add the single JiggleArmature.py and it works. $\endgroup$ – sambler Jun 13 '16 at 7:51
1
$\begingroup$

Addon which name (or folder name) contains . (dot) cannot be loaded in Add-ons list. See this bug report.

Take list below for example:

enter image description here

Lens0.3 cannot be seen in Blender's Add-ons tab. And MultiEdit2.5.py cannot be sucessfully enabled even though it can be found in the list.

Solution would be to manually remove dots or replace with other valid characters.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I'm afraid there's no dots used in my particular file. There is a dash, but removing it hasn't helped. Neither has removing caps. $\endgroup$ – Ascalon Jun 13 '16 at 4:15
  • $\begingroup$ After seeing the addon, it can be solved by directly put the .py file in the addon directory, instead of nesting it in a folder. $\endgroup$ – Leon Cheung Jun 13 '16 at 5:23
  • $\begingroup$ I have and it still doesn't work. I've got it both in addons folder in the install location, and in the app data location, both in and out of the folder. $\endgroup$ – Ascalon Jun 13 '16 at 6:12
  • $\begingroup$ It does work. Assuming you are using Windows OS, then paste it to .\scripts\addons or .\scripts\addon_contrib. Or you can put it to C:\Users\Your_Account_Name\AppData\Roaming\Blender Foundation\Blender\2.7x\scripts\addons. $\endgroup$ – Leon Cheung Jun 13 '16 at 7:28
  • $\begingroup$ I had it in both locations (folder and single.py), but it didn't show up. However, I then deleted it from both, re-unzipped it, and put it in. And now it shows up in either location. It's the exact same zip I had unzipped it from before, so this makes no sense at all. It should be the same file, and I've got it in the same place as before! $\endgroup$ – Ascalon Jun 13 '16 at 8:48
0
$\begingroup$

Solution

If you go to /AppData/Roaming/blender foundation/blender/2.xx/scripts/addons , you will find your installed addons on that version

If some addons aren't showing up, then go to addons folder and modify somethings of that specific addon's file

  1. make sure that there aren't any dots(.), and some symbols like that
  2. make sure that if u open your specific addon's folder, you should directly reach to .py files. I mean , there should not be any extra folders between that path

** It WORKS**

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.