2
$\begingroup$

I have a question about Rigify rig bone selection. When rigify generated done I switched to pose mode to make a key but i couldn't pick a bone what i wanted, just selected wrong bone. It seems weird so I tried to click other bone again but it selected wrong bone again. That seems like first child bone from root bone (I tried many time. Most of all the time it selected the root bone first).

It works fine when it turned off shapes checkbox in Display panel.(Attached image below. 2nd image)

I have no idea whether some options for bone selection toggled on or off(I think those options all probably default)

Isn't it normal.How can I fix this problem? Thanks

My Blender version is v2.77

Work wrong

Work fine

$\endgroup$
2
$\begingroup$

I had the same problem -- digging around the blender bug tracker I found this ticket: https://developer.blender.org/T47940 which describes the problem. I was also using open source gpu drivers.

This is fixed (at least for me) on the latest builds; not yet on the official version (2.77a). If you still have the problem, try a newer version from here, https://builder.blender.org/download/

$\endgroup$
1
  • $\begingroup$ Great!!! It works now. I really appreciate the reply. $\endgroup$ – Cyrus Seong Jul 11 '16 at 13:38
0
$\begingroup$

Try the wireframe (Z) mode in pose mode, and check the outliner if the bone you want to select is actually selectable (it should have activated an arrow on its right). Lots of bones of the rigify rigs are not intended to be selectable and directly posable, they are "machinary" bones.

$\endgroup$
2
  • $\begingroup$ Thank you for your reply. So you meant each bones have to be turned on the arrow (restrict/allow) in outliner so that i can select it? Most of all arrows already activated. I attached video here. sorry if i missed what you meant,cause im not good with english. link $\endgroup$ – Cyrus Seong Jun 12 '16 at 7:28
  • $\begingroup$ I refer to this video link 10:47. I tried same with him but the video seems had no problem. $\endgroup$ – Cyrus Seong Jun 12 '16 at 8:14
0
$\begingroup$

Bone selection works by first finding if the cursor is in an area that the bone shape occupies. You're going to select the root in the above because its occupying screen space, and yes, as you suspected, there is a selection precedence for parents. Even if you aren't clicking on the wiry part of the shape, and just inside of it. When disable custom bone shapes, it no longer occupies that same area, that's why you can select it afterwards.

To select more of the bones you want, you can always turn the visibility of some of the bones in the layers panel. Rigify sorts deform bones from helper and control bones into different layers, so its a matter of finding the right layers. There may also be selectability toggles in the outliner to look at, as josh sanfelici has mentioned.

$\endgroup$
3
  • $\begingroup$ Thank you for your reply. That's what i've got the situation. Here the link it seems what you said. You said the matter was finding the right layers that meant check and toggle the bone layer on skeleton panel in properties right? $\endgroup$ – Cyrus Seong Jun 12 '16 at 7:50
  • $\begingroup$ I tried to toggle and find each layers on skeleton panel which i can adjust like what i wanted but still got the same problem. $\endgroup$ – Cyrus Seong Jun 12 '16 at 7:58
  • $\begingroup$ I refer to this video link 10:47. I tried same with him but the video seems had no problem. $\endgroup$ – Cyrus Seong Jun 12 '16 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.