0
$\begingroup$

I'm having a problem when my meshes exported (to FBX) whereby Blender will smooth the model down.

To replicate the same problem I used Smooth Vertex and as you can see from the before and after the verteces on the barrel have moved. When I import the mesh into UE4 the problem is a lot worse with segments of the mesh completely missing. Its probably down to a fault of my own but this is my first ever modelling project so I'm still learning.

screenshot of mesh before export screenshot of mesh after export

UE4 also displayed this warning message when I imported the FBX mesh.

Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

Any ideas as to why this may be happening would be greatly appreciated.

$\endgroup$
  • $\begingroup$ You got it correct. $\endgroup$ – JOsh Jun 9 '16 at 19:06
  • 1
    $\begingroup$ Did you check your normals? my first impression is that wrongly flipped normals cause these artifacts when enabling smooth shading. $\endgroup$ – Delagone Dec 9 '16 at 15:05
1
$\begingroup$

when exporting to FBX, Blender looks at the Modifier Stack of each object and applies the RENDER modifiers to the object. I can only guess without checking the file, but I suspect that you have a SubSurf modifier on your geometry.

Uncheck the Render Visibility (red arrow is pointing at it in the screenshot) and export again, it should be fine then.

enter image description here

$\endgroup$
  • $\begingroup$ I would try what you have suggested however my model has disappeared from my viewport and whatever I try I cannot seem to get it back. I will just start again and follow your advice when I come to export the model again. $\endgroup$ – JOsh Jun 9 '16 at 18:46
  • $\begingroup$ check the layer settings, you might have simply turned the visibility of the layer off which contains the geometry. Layers can be found in the bottom of the interface, there's 20 small squares, each one representing one layer. Click to turn one of them on. $\endgroup$ – aliasguru Jun 9 '16 at 18:56
  • $\begingroup$ It disappeared when I attempted to add a sub-divide and then after doing so rotate the mesh. No matter which viewport I go into the mesh still isnt visible. The dimensions are also set oddly to very large negative numbers. That issue may have arose when I got angry and pressed any key on the keyboard to get the model back. I $\endgroup$ – JOsh Jun 9 '16 at 18:56
  • $\begingroup$ I pressed on all of the layers and none of them displayed the mesh. $\endgroup$ – JOsh Jun 9 '16 at 18:57
  • $\begingroup$ I have set all of the XYZ location back to 0 however the dimensions are stuck at very large negative numbers and they cannot be changed. The median is also set at -1.#IND (No Idea what this means). $\endgroup$ – JOsh Jun 9 '16 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.