0
$\begingroup$

My aim is to get the leaves-object of a tree to have some transparency generated by the preset cloud texture from blender.
I cannot use cycles render. Is there a way to get that possible though?

Here's a testrender to show my current result
enter image description here
Things I already tried so far:
- set material settings up with a mask-transparency (alpha on 90%)
- texture settings like following:
type: clouds
colors-> ramp enabled,
left side on white with 0 alpha.
right side a color at position 0.771, full alpha.
blending method 'ease'.
mapping is generated, flat (since it's a bunch of single planes)
influencing (diffuse) alpha, color and some geometry settings.
bump mapping is set as best quality and texture space.

[A thing that might happen is a not fitting size of the texture for the objects.]
If anyone out there has got some experiences with a working method, I'd be happy to get some help here.
Thanks^^


blender player: transparency shown properly from down below blender player no transparency shown at all (which is not logicial)

$\endgroup$
  • $\begingroup$ Surprised your question hasn't been answered by now, (14th March 2017) but as as it's been re-presented, I've made two basic leaves and added them to my earlier attempt to answer/reply. More detail is provided at the edited section of the post. $\endgroup$ – Edgel3D Mar 14 '17 at 1:29
1
$\begingroup$

You can use the Value from the cloud texture to get transparency.
Enable nodes, and in material nodes connect the value of the cloud texture to the Output's Alpha.
You can fine tune the amount of transparency by adding a color ramp in between .

enter image description here

$\endgroup$
  • $\begingroup$ Thanks, it made them appear a little transparent now. Somehow not the right method to create petals however. In the end, I will need to create textures therefor I fear. $\endgroup$ – xDonnervogelx Jun 15 '16 at 20:55
  • $\begingroup$ Is the result still bad even with a color ramp? $\endgroup$ – user2816 Jun 15 '16 at 20:58
  • $\begingroup$ Well, it makes the seperate layers not overlap each other where there is transparency but show the world background. I don't think it would help doing color ramp there. $\endgroup$ – xDonnervogelx Jun 16 '16 at 16:04
  • $\begingroup$ @xDonnervogelx, with that World Bkd showing through, try ticking or unticking the "Transparency" box for those leaves. You'll find that under each leaf object's properties at extreme right. (orange cube icon at top of properties) Go down to it's "Display" tab and open that. It's in there. $\endgroup$ – Edgel3D Apr 3 '17 at 0:58
0
$\begingroup$

Try the "Transparency & X-ray tickbox under each object's Properties-->Display. (the orange cube icon at top) That cured my problem when peering through a semmi-transparent surface and losing what was behind it.

-=============-

Edit: 14th March 2017

Surprised your question hasn't been answered by now, but as it's been presented again, I've made two basic leaves and added them here.

They are made from ordinary 2D planes fashioned into the shape of leaves, then textured with leaf images. After some bumping to raise their veins(?), transparency and colour was adjusted.

I am at a loss to appreciate exactly what it is you have in mind here but gather that it's not a botanical representation, rather, employing a measure of transparency and sky colouring along with a soft texture, which is not necessarily leafy.

I've used leafy texture here and not limited the settings in the left hand example in order to demonstrate what can be done in ordinary Blender and OpenGL rendering.

You can scale down the texture's "Color" and "Geometry" sliders in the Influence tab for much softer and perhaps even 'mystical' results with the right shading and lighting. You can also use any texture you like but using one that's alpha layered can add complication.

An alpha layered texture would normally require the Material's "Transparency" slider to be at zero already. The texture's opacity slider could be adjusted for a single image but cannot be keyframed (varied) if producing video.

The compositor may be able to override this but you'd then be back in Blender's render and results might look entirely different.

In the example shown in your question you mentioned that the leaves were planes, so the setup described here would be possible with the leaves as placed.

The varied angles that they hang at will affect how the bumping will appear so you may have to add weak point lights here and there, or create different material slots for some leaves and adjust those texture and material settings to compensate

In brief - the above was rendered in OpenGL, and put together using ordinary Blender.

$\endgroup$
  • $\begingroup$ Thanks for that tip, I used it on a different object which is for hair (texture affects alpha value). It now shows the transparency in texture mode. Still, it doesn't render as expected. The backface culling seems to be disabled. I am still trying to figure out, what causes this. I worked with game engine for a while and going back to blender render is getting difficult. Something is fishy here... $\endgroup$ – xDonnervogelx Nov 29 '16 at 17:55
  • $\begingroup$ You're most welcome. I did elaborate elsewhere on this site regarding interaction between transparent surfaces that are behind each other, but can't find it now. Basically-parenting the one behind to the front one will make the rear one disappear when the front's transparency is set to .008 or thereabouts and this effect can be cancelled by joining the two together and then seperating the back one in Edit mode, using key 'P'. If you're tempted to try this, copy your Blend file to a temporary one first, do it on the copy! $\endgroup$ – Edgel3D Nov 30 '16 at 0:51
  • $\begingroup$ I've just seen you added some info to your answer. Since it's been so long ago, I have to overthink the whole issue a few times. Maybe I'll comment again if it comes better to my mind. I do get the part with having flat or almost flat planes. Seems, that somehow the objects themselves are overlapping their own surfaces, when they have got a more complicated shape. Oh, and please tell me, if I misunderstand your explaination. It's hard to follow sometimes, since I am not natively speaking english... $\endgroup$ – xDonnervogelx Apr 1 '17 at 18:00
  • $\begingroup$ So... I just tested the things with setting alpha down and started player on a new file. It only worked on one side. Which is strange. I had two transparent planes, same settings for both, selected around but only from below I could see through both planes. So this must mean this is a bug by blender itself? I could add the pictures I took out of it just this minute. $\endgroup$ – xDonnervogelx Apr 1 '17 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.