0
$\begingroup$

I go this set up to show, I put A Movie in, then went to nodes, added the movie, scale set to render size, and rendered layer is connected to Alpha over connected to composite .. the model is barely showing up .... I had to add emission to the material to the model to get it to do that, but it is not even very realistic looking.

$\endgroup$
  • $\begingroup$ you didn't pack the textures/movies to know what it looks like , use a color correction on the model to match colors with the video footage, see this if you want other compositing node setups $\endgroup$ – user2816 Jun 8 '16 at 20:15
  • $\begingroup$ @root I'll check that out , I'm watching youtube masking stuff into movies right now, thanks! $\endgroup$ – uxserx-bw Jun 8 '16 at 20:20
  • 1
    $\begingroup$ you don't need to mask the background color , in the render settings under film enable Transparent... $\endgroup$ – user2816 Jun 8 '16 at 20:21
  • $\begingroup$ @root it is enable on that -- let me check again, it might have been a different file I did that on, and that matching colors, you can see right through that modle against whatever is in the movie. $\endgroup$ – uxserx-bw Jun 8 '16 at 20:39
  • $\begingroup$ @root how does one make it look like a solid object? it is transparent .. $\endgroup$ – uxserx-bw Jun 8 '16 at 20:46
0
$\begingroup$

I did not have your movie, so I substituted a brick image. I was able to achieve this result:

enter image description here

As you can see, it is not transparent at all, and nor is the brick background weird. I used this RenderLayer node setup:

enter image description here

Note the values in the Alpha Over node, which I changed to 0 and 1. The 0.527 for the Fac: value would have made your model transparent. The Premul: value could have led to the background distortions. Also note that I checked Transparent in the Properties panel > Render tab > Film dropdown. The modified Film dropdown should look like this:

enter image description here

Here is a modified .blend file. You will have to substitute your video back in to the RenderLayer node setup, though.

| improve this answer | |
$\endgroup$
  • $\begingroup$ that is exatly how I have it set up. but that ship, the background shows through it. It too maybe a question of coloring it, the how to's behind that too in order to get it to look more realistic as well. I'll check my settings when I can get a min. right now I am doing a video edit for a different project. Thanks $\endgroup$ – uxserx-bw Jun 9 '16 at 14:46
  • $\begingroup$ sorry been doing / trying many things at once... w/blender... thanks for the help $\endgroup$ – uxserx-bw Jun 9 '16 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.