I'm trying to make an animated pixel art sprite. I can render it no problem at its normal size settings, but when I set the image size extremely low, it doesn't come out like it should in avi jpeg form. When I render the sprite at its full resolution, it looks like this: enter image description here

I tried to pixelate it by setting the resolution extremely low, and got this: enter image description here

That's what I want. I want the image to be pixelated, but when I export the full animation as an avi jpeg video, it completely blurs the image beyond all recognition because it's such a small image. This is what the output looks like: enter image description here

How do I render / export / format / scale the image such that I will get a sharp, clean pixel animation, with every frame looking like the second picture?

  • 1
    $\begingroup$ Avi doesn't support alpha transparency , and jpeg is not lossless and will smooth things out, but i don't think this is the problem.. $\endgroup$
    – user2816
    Commented Jun 7, 2016 at 1:41
  • 1
    $\begingroup$ Not sure where a setting is or what codecs work with this, but the term I think you are looking for is "interpolation", you want that off. What program are you viewing the exported animation in? It could be that program just smooths the image to whatever scale. $\endgroup$
    – Gliderman
    Commented Jun 7, 2016 at 1:52
  • $\begingroup$ @root Does blender support a format that doesn't compress and supports alpha? $\endgroup$
    – Sanix25
    Commented Jun 7, 2016 at 1:53
  • $\begingroup$ yes,you can export as h264 and enable lossless output , or use avi raw instead of avi jpeg. $\endgroup$
    – user2816
    Commented Jun 7, 2016 at 1:58
  • 3
    $\begingroup$ Make the pixelation on the compostitor so you can render at the desired frame size but with the pixelation effect. Read: blender.stackexchange.com/questions/39859/… $\endgroup$
    – user1853
    Commented Jun 7, 2016 at 2:16

1 Answer 1


You can use a Pixelate node in the compositor. Go to the Compositing Screen Layout or open a Node Editor some other way. Make sure the Compositing Nodes button is selected.

enter image description here

Use the following setup. Notice how the left side of the gun is pixelated, but the right side is normal. In the final render, it will all be pixelated. Additionally, see how the both Scale node's X and Y values are equal. Also notice how between them they equal 1 (0.2 x 5 = 1). This means that the overall scale of the gun image doesn't change.

enter image description here

If you so desire, you can copy the node setup straight from the following file (gun not included) (sorry) (it does include an awesome hippie monkey, tho). Lastly, you can read more about the Pixelate node here.


enter image description here


enter image description here


Not the answer you're looking for? Browse other questions tagged .