7
$\begingroup$

I have 2 animations currently on a sword that I have modeled and when I export the object as a fbx into my game engine Unity it seems to not bring the animations along with it. Here are the export settings: enter image description here

and here is what it looks like when imported into Untiy: enter image description here

As you can tell I am very new to blender and modeling in general so any tips on where I have gone wrong would be appreciated. Thanks! I apologize for the poor resolution on the second screenshot.

$\endgroup$
  • $\begingroup$ Can you share the model with the animations (the blend file). I just tried this on a cube with two keyframes using the default settings and it worked. $\endgroup$ – iKlsR Dec 14 '13 at 19:13
  • $\begingroup$ Heres a link to the file. Thanks dropbox.com/s/qs4cj3kw9wv7znu/weapon.blend $\endgroup$ – Riley Shaw Dec 14 '13 at 19:31
  • 2
    $\begingroup$ How do you take such a high resolution screenshot of the Blender UI? $\endgroup$ – Keavon Dec 16 '13 at 4:14
  • $\begingroup$ Create your animations in Pose mode rather than Object and the problem is solved :) $\endgroup$ – user31273 Oct 8 '16 at 14:10
  • $\begingroup$ just drag and drop the blend file to unity assets folder, it'll work $\endgroup$ – Ijas Mohmmed Apr 25 '17 at 12:39
5
$\begingroup$

When exporting, tick Include Default Take. Also, since you aren't using bones, you should apply the scale on the model before exporting (CtrlA > Scale).

enter image description here

The animation(s) should now come over with the selected one (in Blender) as the default take.

enter image description here

$\endgroup$
  • $\begingroup$ I had done that before but it doesnt take both of the animations over... I have two animations created called attackleft and attackright.. With this method i only get attackleft $\endgroup$ – Riley Shaw Dec 14 '13 at 19:43
  • $\begingroup$ @RileyShaw I don't think this is possible, it seems you have to export these on one timeline and split them up in Unity. See this and this. $\endgroup$ – iKlsR Dec 14 '13 at 19:46
  • $\begingroup$ @RileyShaw I don't think the format is the problem here. I dropped the blend file into Unity and it only came in with one animation. What most people do it seems is to create multiple files for the different anims.. character.walk, character.run etc or drop animations on a single timeline and split it up. $\endgroup$ – iKlsR Dec 14 '13 at 19:53
  • $\begingroup$ Ooooh ive got it now. I didnt realize that Unity has the option to split up one main animation into different animations. Thanks! $\endgroup$ – Riley Shaw Dec 14 '13 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.