7
$\begingroup$

When I render an image, the "Image" menu has an option to "Edit Externally" but I can't get it to work. Would love to render, then edit in Photoshop. Can anyone help? I've tried setting the "image editor" in user preferences.

Thanks!

$\endgroup$
8
$\begingroup$

You have to set the associated image editing program in User preferences > File first. Next, make sure that the image is saved to disk (you can use F3) and it should work.

enter image description here

When saving, use Save As Image and untick Save as Render and Copy but keep Relative Path.

enter image description here

$\endgroup$
  • $\begingroup$ I have set this but no joy :( .I should have added this in my original message but I get an error when I click "Edit Externally": "Image path '.' not found, image may be packed or unsaved" However I have DEFINITELY just click "Save As Image" and saved the file in my project folder! $\endgroup$ – user1841 Dec 13 '13 at 12:09
  • $\begingroup$ @user1841 See updated answer. $\endgroup$ – iKlsR Dec 13 '13 at 12:10
  • $\begingroup$ Tried unchecking box but still wrong. Noticed that if I do "Save As Image" (F3), save it, then immediately do "Save Image" (Alt-S) I get error "Cannot save image, path '' is not writeable". I would expect it to save it in the same place as F3. Obviously it's not looking in the correct place :( $\endgroup$ – user1841 Dec 13 '13 at 12:13
  • $\begingroup$ SUPERSTAR! Works! I didn't have the "Relative Path" (thought we were just on different versions). It appears when unchecking "Copy" and makes all the difference! Thanks a million! Here are a few more exclamation marks for safety!!! $\endgroup$ – user1841 Dec 13 '13 at 12:16
  • $\begingroup$ @user1841 This was an old bug that has come back somehow it seems. Reported and a developer has claimed it. $\endgroup$ – iKlsR Dec 13 '13 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.