2
$\begingroup$

I am guessing you guys get this a lot, but I've tried everything to fix the Bone Heat Weighting Failed error. I have no idea what to do, so if you guys can somehow fix this, then you're amazing.

.blend file below:

$\endgroup$
0
$\begingroup$

Got it. The use of a Decimate object modifier can aid in solving your problem. Note that in my rigging of your mesh, I changed the names and added a bone between the feet. This can be used to move all bones, as all other bones are parented to it.

Solution

Go to the Object modifier tab in the Properties panel and delete any Armature modifiers. Add a Decimate modifier from the dropdown. Select Planar from the three options and set the Angle Limit: value to 6.4. It should look something like this:

enter image description here

Apply the Decimate modifier. Next, select your mesh and then your armature. Key Ctrl + P to open the parenting pop up menu and select With Automatic Weights under the Armature Deform section. The option should look like this:

enter image description here

After a second or two, it should be finished. Here is a .blend file if you want to just download it:

$\endgroup$
  • 2
    $\begingroup$ so it didnt work because it had too many vertices? $\endgroup$ – eromod Jun 4 '16 at 2:41
3
$\begingroup$

You need to " set origin to geometry" for the mesh.

The button is located in the (t)toolshelf-->Edit-->SetOrigin

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.