1
$\begingroup$

I've been working on a project for a while now, and recently Blender seems to crash whenever I try to bake the fluid involved in that scene. In User Preferences > System > Memory Cache Limit (Under Sequencer/Clip editor) I have set to 2048mb. I have 8GB of RAM, so this should be fine. Also, I have no external programs running when I do this. Observing the Blender process in Task Manager, when I begin baking it's RAM usage bumps up to almost 5 gigabytes, for no reason. Is there some kind of fluid cache that I could have filled on accident? .blend file here.

$\endgroup$
  • $\begingroup$ Josh, I have read a lot of your posts, and you should consider starting to use Blend Exchange rather than Google Drive to store your .blend files. Unlike Google Drive, Blend Exchange links will never go down. This helps people continue to learn from your posts for months and years after. Thank you for considering. $\endgroup$ – Shady Puck Jun 2 '16 at 18:41
  • $\begingroup$ "For no reason" is not really the case her... Geometry uses memory. Fluid simulation creates a lot of vertices, Those take up RAM... potentially a lot of it, depending on the resolution you are aiming for... So if your system is crashing it is possible that you are dealing with a scene that exceeds the capabilities of your current system. Try reducing the resolution of the simulation. $\endgroup$ – cegaton Jun 3 '16 at 0:07
  • $\begingroup$ @cegaton except my computer CAN handle the scene. I've baked the fluid multiple times in the same scene and never had issues. Then I make a minor change to the position of the pan and my computer starts crashing upon baking. Even after reverting the changes I made, it still crashes. $\endgroup$ – Josh Silveous Jun 4 '16 at 0:50
  • $\begingroup$ Could you run Blender from a terminal and see what output you get? - blender.org/manual/render/workflows/command_line.html Typically errors are printed before crashing. $\endgroup$ – ideasman42 Jun 4 '16 at 1:04
  • $\begingroup$ @ideasman42 Already tried it, but no errors show up because blender doesn't just crash, my whole computer does and I have to restart. $\endgroup$ – Josh Silveous Jun 4 '16 at 1:06
4
$\begingroup$

The cache limit in the user preferences only limits how much memory can be used by clip editor and the sequencer to preload frames for faster playback.
Fluid simulations are not limited by that value.


You can bake the simulation from the command line without loading blender's interface.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.