0
$\begingroup$

Okay, I just learned how to bake an AO lightmap for an object and how to blend it with another texture (thanks to the people here), and it looks just great when rendered, but for some reason the object looks almost black when I view it in the BGE. My other objects that have just one texture mapped to them look normal in the BGE. Here's an image of the object in the BGE:

Object in BGE

Also, the AO texture shows up in Texture mode in the 3D viewer, but not the other texture that I blended it with. Here's an image to show you what I mean:

Object in Texture mode

Here's an image of the object when rendered. Note that the AO is barely noticeable (another issue?):

Object when rendered

And for posterity, here's how I have my texture nodes set up for the object:

enter image description here

$\endgroup$
4
  • $\begingroup$ in your material node you are blending texture 012 with a color and not with texture 005, or is this how AO blending works? $\endgroup$
    – user2816
    Jun 1, 2016 at 22:24
  • 1
    $\begingroup$ That's how I was shown to do it. I'm just following instructions from another post. I assume the answer was given by someone who knows what they're talking about. Maybe they don't. $\endgroup$ Jun 1, 2016 at 23:48
  • $\begingroup$ It looks like the second texture is connected to the wrong slot. It should either be connected to the Color 2 socket (not factor) or you should be mixing it with a dark or black color, not white. $\endgroup$ Jun 2, 2016 at 1:26
  • $\begingroup$ I just tried changing the node set-up as you suggested, and there's no difference. I also changed the material from white to black, but again, no difference. $\endgroup$ Jun 2, 2016 at 2:13

1 Answer 1

1
$\begingroup$

This is the node setup I would suggest: enter image description here And the 'Fac' slider will adjust the strength of the AO effect.

Things that may stop your AO/node shaders from working:

  • You're in multitexture mode (you must be in GLSL mode for node shaders to work)
  • You have node textures disabled (render settings, GLSL, the checkbox labled 'nodes')
  • You have unticked the 'use node shader' button for the material. I consider this most likely.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .