2
$\begingroup$

When I am in Textured view, I can't see my textures from afar. It is almost as if the camera is emitting a light. I can, however, see my textures normally when I am extremely close to (a textured object). I made a video showing my problem. Note that it does render perfectly. Lastly, I use Blender Game Engine the most, so I need it to work properly for quick building. Any suggestions?

$\endgroup$
  • $\begingroup$ Looks like it can't tile the texture. It also takes a bit to load the texture, maybe is something realted to drivers or similar. Since when you are experiencing this behaviour? It's the first time? Was it all fine before? $\endgroup$ – Carlo Jun 1 '16 at 21:52
  • $\begingroup$ apply the scale on your ground plane. shouldn't make a difference, but it might. $\endgroup$ – X-27 wants to Reinstate Monica Jun 1 '16 at 22:09
  • $\begingroup$ What are you using for illumination? Try putting a hemi light near the object and see if that changes things. $\endgroup$ – Anthony Forwood Jun 1 '16 at 23:58
1
$\begingroup$

This looks to me like it may an issue with being in multi-texture mode. In multitexture mode, lighting is calculated per vertex. This means that the lighting on a giant plane is calculated at the corners. Because these are a long way from the light, this means the corners are black, and this extends towards the camera.

There are two ways I see to fix this if this is the case. The first is to switch to GLSL mode. GLSL mode calculates lighting per screen-space pixel and provides much better looking results (also allows normal maps etc.) The second is to try subdividing the plane such that the lighting resolution is higher. If your computer is old, this may be the only option to provide decent performance.


Another possible cause is mist. Again, in multitexture mode this is vertex based. Check that mist is disabled. You may have accidentally made your default blend file have a misty world.


A final possible problem may be your GPU or it's drivers. It may not be calculating mipmaps correctly in which case either a driver update may fix it, or using .dds textures (which contain pre-defined mipmaps) could solve it.


If none of these provide a solution, upload a blend file and I'll see if the issue is replicated on my computer

| improve this answer | |
$\endgroup$
  • $\begingroup$ I have tried switching it to GLSL Shading mode, but to no avail. I have a fairly old computer (2009), but I don't see this to be the problem, since my old computer was from 2001 and I didn't have this problem. I can try subdividing it, and I will post my results, and I do not have mist on. It could be a problem with my GPU, but I wouldn't have any way to find out. Thanks for your feedback though, I appreciate it. (By the way, I am writing this after registering for the site, so I can't comment) $\endgroup$ – user25231 Jun 2 '16 at 18:50
  • $\begingroup$ Can you upload a blend so we can have a look? $\endgroup$ – sdfgeoff Jun 3 '16 at 9:21
  • $\begingroup$ The last bit of the video looks like you enabled mist. $\endgroup$ – Monster Jun 7 '16 at 5:10
  • $\begingroup$ 0:50 looks like the texture does not get wrapped (no repetition when the texel is outside the texture). $\endgroup$ – Monster Jun 7 '16 at 5:12
  • $\begingroup$ Oups, the above two comments where meant to be under the Question. Finally I agree with this answer. In Multitexture the shading is interpolated along the face edges. As the far away vertices are dark, the texture seams to fade out. Local light sources will not change anything unless they illuminate the far away vertices too. The ground is simply to large. $\endgroup$ – Monster Jun 7 '16 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.