1
$\begingroup$

I'm brand new to Blender. I've made three short videos with the most editing done to them being fade ins and fade outs and added audio. Never had a problem rendering those.

My new project, however, is a 30 minute clip with some parts sped up using speed control strips. After I finished those edits, I grouped all the clips into a meta strip and added a "global" speed control to shrink the entire film down to ~8:20, to fit with a song I want to add to the video.

Problem is, at around 8% or 9% rendered, I start getting "Error Writing Frame". Here is a screenshot, which also shows my render settings.

I thought maybe I was running out of memory or something, but I don't know how to check if that's the case. The "Mem:" in the top right corner hovers around 1840M. I tried just rendering the video, without an audio track, but I still run into the same issue.

I'm not sure how to find output logs and stuff like that, and I'm not sure exactly what I need in order to get support. Any help is appreciated, thanks!

$\endgroup$
  • $\begingroup$ do you have enough disk space ? a 30min lossless 60fps video will take a lot of disk space, and by default it will use an .avi container which won't handle >2GB file size, try ticking autosplit output $\endgroup$ – user2816 May 31 '16 at 22:20
  • $\begingroup$ I do have enough disk space, but I didn't realize there was a size limit. I'm a little confused though. I know h264 is a codec, but isn't it also a container? In my render settings, it's set for h264 as the container, with h264 encoding. Should I be using MPEG-4 as the container? Or am I going about this all wrong? $\endgroup$ – blorgon May 31 '16 at 23:02
  • $\begingroup$ to confuse you even more , h264 is a compression standard, x264 is an implementation of h264 and is the codec, but it's not a container. blender will use the avi container when you set the output format to h264 since .avi is very well supported by most platforms and systems than, for example, MPEG-4 or matroska. and yes you should use .mp4 container if you render large videos. $\endgroup$ – user2816 May 31 '16 at 23:49
  • $\begingroup$ Okay, so... there's the output file format, and the output video format? Should I do MPEG, MPEG-4, and h264? $\endgroup$ – blorgon May 31 '16 at 23:54
  • $\begingroup$ yes , like this. opening the video in vlc reports it's a h264 encoded video. $\endgroup$ – user2816 May 31 '16 at 23:57
0
$\begingroup$

Needed to change render settings to a different output file as described by @R00t:

a 30min lossless 60fps video will take a lot of disk space, and by default it will use an .avi container which won't handle >2GB file size, try ticking autosplit output

h264 is a compression standard, x264 is an implementation of h264 and is the codec, but it's not a container. blender will use the avi container when you set the output format to h264 since .avi is very well supported by most platforms and systems than, for example, MPEG-4 or matroska. and yes you should use .mp4 container if you render large videos.

$\endgroup$
  • $\begingroup$ can you please link a source for this information? As far as I know the only size limit for AVI files is set by the disks to which the file gets saved to. Older FAT or FAT 32 formatted drives can only have files up to 4GB. Where is this 2GB limit coming from? $\endgroup$ – cegaton Jun 3 '16 at 0:28
  • $\begingroup$ @R00t was the one who mentioned it, and it sounds like it's more of a Blender limitation. $\endgroup$ – blorgon Jun 4 '16 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.