2
$\begingroup$

Not sure what these are but they seem to appear only on certain edges. I've already checked there's no intersecting geometry and all the normals are facing the right way. Does anyone know what these are and how to get rid of them?

$\endgroup$
2
  • $\begingroup$ Try to flip normals? And what do you use as a factor in mix shader? $\endgroup$
    – Denis
    Commented May 31, 2016 at 20:40
  • $\begingroup$ Flipped the normals and nothing changed. I'm using a Fresnel as my mix factor. After further testing i discovered This only happens when I raise the model to a certain height above the grid floor. I have the model positioned on the highest level of a multilevel city I'm designing. When I moved the whole top layer of the city along with the character down to the grid floor, the black lines went away. Strange. Any idea why it does this? $\endgroup$ Commented May 31, 2016 at 23:48

1 Answer 1

4
$\begingroup$

The problem comes from your subsurf.
using the "adjust edit cage to modifier result" option will show you a mesh that is not the real mesh. Sometimes it helps but editing without checking the real mesh can be tricky.
subbd cage
In you case you have edge loops overlapping, you'll see it if you disable this option.
no subd cage
you can fix this by moving you edge loop away with GG (edge slide)

$\endgroup$
2
  • $\begingroup$ After further testing I discovered This only happens when I raise the model to a certain height above the grid floor. I have the model positioned on the highest level of a multilevel city I'm designing. When I moved the whole top layer of the city along with the character down to the grid floor, The black lines went away. Strange. Any idea why it does this? $\endgroup$ Commented May 31, 2016 at 23:48
  • $\begingroup$ Can't guess more without the Blend file, you can post it here. From your screenshot, it could be the armature not visible in 3D view but activated for render. $\endgroup$
    – Bithur
    Commented Jun 1, 2016 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .