0
$\begingroup$

I installed blender 2.77 (latest update) and used a model created in 2.75. In the face mesh I used two modifiers, subsurf and beneath that a normal edit modifier to have control over the sahdow on the face. In some weird way it is producing jagged edges on the jaw area (where the normal edit modifier has effect). Auto smooth in the object data is on. enter image description here

Anyone has an idea what is causing this?

$\endgroup$
7
  • $\begingroup$ Are you using freestyle? I have never used the Normal Edit modifier, but could it be somehow inverting the normals and what you are seeing there are backface artifacts? $\endgroup$ May 31, 2016 at 23:15
  • $\begingroup$ Interesting thought but freestyle is an line renderer and would not change normals that way. Besides it worked in 2.75 even using freestyle., $\endgroup$ Jun 1, 2016 at 19:56
  • $\begingroup$ I mean that the Normal Edit modifier modifier was somehow erroneously changes the normals not FreeStyle; FreeStyle can't do that alone. I have no idea what could be causing that but it certainly looks like inverted normals. Hard to tell without more info. Could you share the blendfile? $\endgroup$ Jun 2, 2016 at 1:21
  • 1
    $\begingroup$ Well discussed the topic within the facebook NPR community and even if I use a plain unshaded susanne the same problem popped up. So it is either one of my user preferences or just a bug. Wait for someone to reproduce the same result with latest 2.77 build and then will report it. $\endgroup$ Jun 2, 2016 at 19:20
  • $\begingroup$ feedback1 This is not a bug actually. Issue here is that your are pushing normals way out of the 'safe area', making many of them reversed compared to default ones (computed from neighbor face normals). Up till 2.76, Blender did not handle correctly that 'inversion of normals', leaving face normals opposed to its vertices ones, which was really bad and inconsistent. Since 2.77, winding of such faces is now reversed, to make face normal match the direction of its vertices ones. $\endgroup$ Jun 7, 2016 at 16:52

1 Answer 1

1
$\begingroup$

The problem has been solved. In the latest build an extra option has been added to the normal edit modifier. It is a field called "Max angle". Standard it gives a volume of 180 degrees. As explained by the developer, if you bring this value below 90 degrees (say 30) it prevents the normals from inverting and producing the jagged edges. Thanks for this life saver Bastien.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .