0
$\begingroup$

I don't know why this is happening, but my water simulator is not working. Here is my setup: Setup

The selected object as well as the other big object are both obstacles. There is a rectangle at the top as the inflow and another at the bottom as the outflow. The whole thing is surrounded with a cube that is the domain (it is hidden now). Basically, it is a slab then a drop then a slab. A side view looks like this:

000000000  
x       0
ooooooo 0
      o 0
      o 00000000
      o        y
      oooooooooo

o - Object 1, obstacle
0 - Object 2, obstacle
x - Object 3, inflow
y - Object 4, outflow

And a cube as the domain surrounding all of that. I have the default settings on all except for no slip and some velocity on the inflow and water on the domain for viscosity. When I bake the domain just stays a cube. What would cause this?

The blender file:

$\endgroup$
  • $\begingroup$ Could you upload your .blend file to here? $\endgroup$ – Shady Puck May 30 '16 at 21:32
  • $\begingroup$ @ShadyPuck done. $\endgroup$ – Dylan Siegler May 30 '16 at 21:36
1
$\begingroup$

Share the file just to make sure, but you can try to set the volume initialization on all the objects to both, and make the domain object larger.

$\endgroup$
  • $\begingroup$ One of those seemed to have done it $\endgroup$ – Dylan Siegler May 30 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.