0
$\begingroup$

I am creating an inflatable pink flamingo in Cycles, and there is an ugly black line at the edge of my mesh that I don't know how to get rid of. Here are my materials and a sample render. How do I get rid of the black lines at the edge of my mesh? enter image description here

enter image description here

$\endgroup$
4
  • $\begingroup$ Maybe your lighting, how does it look in solid shading? Have you checked for any overlapping geometry? $\endgroup$
    – Timaroberts
    May 30 '16 at 6:18
  • 2
    $\begingroup$ @corgijumper, maybe you could be so kind as to upload a copy of your ~.blend file to blend-exchange, and edit the link to the file into your quesiton. $\endgroup$
    – brasshat
    May 30 '16 at 6:21
  • $\begingroup$ This can be a bad alignement of the vertices around the x-axis (bad clipping or no clipping in the mirror modifier) $\endgroup$
    – lemon
    May 30 '16 at 6:40
  • $\begingroup$ Upload your file please $\endgroup$
    – Jml19
    May 30 '16 at 9:33
1
$\begingroup$

First, it is hard to tell without your .blend file, but I believe I have a two part solution.

Part 1

Many of your nodes are repetitive and unnecessary. You would get a near-identical result with just the following. Use the Layer Weight node's slider to affect the glossiness (higher value = more glossiness).

enter image description here

Original node setup vs. My node setup:

enter image description here vs. enter image description here

Part 2

I assume you have Smooth Shading on, as activated in the Toolshelf. If you do, either return to Flat Shading or add a Subdivision surface object modifier.

To add such a modifier, first go to the Object Modifiers tab in the Properties panel. Select Subdivision surface from the options. Set both the View: value to 2 and the Render: value to 3.

Final modifier settings:

enter image description here

Smooth shaded Suzanne without any subsurf:

enter image description here

Smooth shaded Suzanne with subsurf at 3:

enter image description here

Flat shaded Suzanne:

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you! I was able to fix the lines around my mesh this way! $\endgroup$ May 30 '16 at 17:13
  • $\begingroup$ @corgijumper If you liked my answer, please consider accepting it. $\endgroup$
    – Shady Puck
    May 30 '16 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.