5
$\begingroup$

I am trying to place long benches on a lot of edges in a park. I decided to use Curves with a bevel object for that. I placed edges on the places where the benches need to come and converted the mesh to a curve. There I added a bench profile. I placed the origin point of the bench profile to the bottom so I thought that works without problems. Now does the problem occur that the profile is randomly rotated over the curve like you can see on the image below. These images are taken on different positions in my park.

enter image description here

Of course, I did try to search for a similar problem and what I found here is that you need to rotate the profile in edit mode but that does not solve the problem because it keeps the different rotations but then just from another angle. Also is this inaccurate because you never know when it is horizontal.

So what I want is that the broader part of the profile (to sit area) is placed on the top on every part of the curve.

Here my curve (all parts are in one curve), my curve settings and the bench profile: enter image description here enter image description here enter image description here

Can somebody help me with placing the bench profile correctly placed across the entire curve

Thanks in advance


Solved

What I did is create the curve directly from a curve instead of converting a mesh to a curve. I still want to thank everybody who gave suggestions that should work in normal situations.

$\endgroup$
  • $\begingroup$ Related: blender.stackexchange.com/questions/16523/… and also: blender.stackexchange.com/questions/35771/…. $\endgroup$ – Carlo May 29 '16 at 12:41
  • $\begingroup$ @Carlo Thanks for you answer. I test both "Z-up" and "Tangent" but non of them work. It does not even rotate when I change the setting. $\endgroup$ – Vinc199789 May 29 '16 at 12:52
  • $\begingroup$ Did you also tried clearing the tilt? Maybe if you could upload a sample of your file, we can have a better look at the issue $\endgroup$ – Carlo May 29 '16 at 13:10
  • $\begingroup$ @Carlo, I solved the issue, I added an answer where you can find what I did. Still thanks for helping $\endgroup$ – Vinc199789 May 29 '16 at 13:14
  • $\begingroup$ @Carlo, Here the file for in case you still want to see what could be wrong. Select benche in the first layer. In the second layer I placed a object: benche 2 that is working: onedrive.live.com/… $\endgroup$ – Vinc199789 May 29 '16 at 13:17
4
$\begingroup$

Apply Rotation

Object Transformations are the latest thing that affect your mesh appereance, even after modifiers.

enter image description here

All the curve related options (including the Twisting type) consider the un-rotated mesh, that in your case look like this:

enter image description here

only after that the rigid rotation of the object occours, so the benches will not result having the Twisting type you expected.

Applying the rotation (Crtl+A) will let use the curve's options directly upon the final mesh orientation.

$\endgroup$
  • $\begingroup$ Okay, thanks for the explaination. How can I fix the problem from this sitiuation? $\endgroup$ – Vinc199789 May 29 '16 at 13:44
  • $\begingroup$ By applying the rotation for the "bench" object. Then I would suggest to also switch the curve to 2D for a better corner solution of the beveling. $\endgroup$ – Carlo May 29 '16 at 13:55
  • $\begingroup$ Well, thank you for you time and clear explainations. Have a nice day :) $\endgroup$ – Vinc199789 May 29 '16 at 14:02
1
$\begingroup$

If your benches are all placed at the same level (absolute height) try converting the spline to a 2D curve.

Also keep your section profile as a 2D curve either way.

If not then enter edit mode in your bench path and try clearing tilt on all vertex by entering edit mode and pressing Alt + T.

If that still doesn't help switch the twisting from Minimum to Z Up.

If some segments have the bench on the "wrong side" you can then select one vertex of that curve spline and press the Switch Direction button in the Tool Shelf.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.