2
$\begingroup$

Plane object selected but not visible:

enter image description here

For some reason, when I try to add a Plane mesh, it doesn't appear in the 3D Viewport no matter how much I scale it. It's as if it's invisible. I even tried changing the dimensions but they reset to 0. What have I done? How do I fix this? Note that it's only the plane mesh that's acting up.

$\endgroup$
3
$\begingroup$

Problem

You cannot scale it because of the Zero-product Property. This is a mathematical theorem that Hotmath defines by saying:

The Zero Product Property simply states that if a*b=0, then either a=0 or  b=0 (or both). A product of factors is zero if and only if one or more of the factors is zero.

This relates to your issue because you are trying to multiply the dimensions (let the Object Dimensions be represented by a) -- set at 0 -- by a non-zero value (let that random, non-zero value be b). As Blender follows the various laws of mathematics, the dimensions will always return to zero.

Solution

When first you add a Plane object and before you click on anything else, you should be presented with a number of settings in the Toolshelf on the left side of the 3D Viewport. Make sure the Radius: value is set to a non-zero value. If it is set to zero, it will likely spawn at zero each time you try.

Bad:

enter image description here

Good:

enter image description here

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.