1
$\begingroup$

I have a scene with 2 Cubes, Cube 1 (using a soft body (Rigid body doesn't work either))falls through Cube 2, and Cube 2 has a particle system on it. I want Cube 1 to "push away" the particles on Cube 2 however, goes straight through. I have Collision physics on Cube 1, but it doesn't seem to interact with the particles at all.

Here is my .blend file:

also: to clarify, i don't want the two cubes to collide, I want the particles on Cube 2 to colide with Cube 1

$\endgroup$
  • $\begingroup$ Can you add some more details or a screenshot? $\endgroup$ – Shady Puck May 28 '16 at 20:11
  • $\begingroup$ And I have soft body physics on the thing that falls. Maybe that's why? $\endgroup$ – snipers500 May 28 '16 at 20:14
  • $\begingroup$ That's possible. If your running a simulation on an object, Blender might want particles to collide where the mesh was initially. $\endgroup$ – Shady Puck May 28 '16 at 20:15
  • $\begingroup$ Is there a fix? add it as an answer if yes. $\endgroup$ – snipers500 May 28 '16 at 20:17
  • $\begingroup$ Can you upload a .blend file to blend-exchange.giantcowfilms.com ? I could then look more closely. $\endgroup$ – Shady Puck May 28 '16 at 20:19
1
$\begingroup$

I see what you were trying to do with the Soft Body Physics, but what you really need is a Rigid Body Physics simulation. You can learn a bit about it in this quick, fun tutorial, but it is basically a simplified physics engine for gravity and whatever else you want to have affect your meshes.

For the falling-through-the-bottom-box issue, I turned off Collision Physics for all of the meshes except the floor because it has to deal with the particles. I changed some settings to make the particles bounce nicer. I also added all of the meshes to the Rigid Body Physics simulation. You can tell this because when you select them, the outline is green instead of orange. Additionally, I adjusted the particle settings so that they began emitting at the collision of the two boxes.

Final result:

enter image description here

Here is the modified .blend file:

$\endgroup$
  • $\begingroup$ It works nicely, but it's not the look I was looking for. $\endgroup$ – snipers500 May 29 '16 at 15:24
  • 1
    $\begingroup$ @snipers500 Perhaps you could have added more details about the look you were looking for in your question? I did the best I could and made some assumptions based on limited data. I do apologize if it didn't work for you. However, you said in your answer that you changed to rigid body physics? So maybe my answer helped a bit? If it did, please consider accepting it. $\endgroup$ – Shady Puck May 29 '16 at 16:00
0
$\begingroup$

If you don't need soft body you could use ridged body. Just add rigid body on both cubes. Remove soft body on all of the cubes/objects. The add ridged body on the plane and check animated.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.