2
$\begingroup$

I'm using Blender 2.77. When I import footage into the VSE with the correct frame rate (23.98fps) every single audio strip is 2 frames longer than the corresponding video clip. I think the problem is that my recordings are actually 23.97fps. The issue with that is that when using the custom fps setting there are not enough decimal places to input a value that will result in a frame rate of 23.97 (i.e. 1.0015). I'm not positive this will fix it but I think it should. Does anyone else have any ideas or experience with this issue?

$\endgroup$
1
$\begingroup$

First off many others have had this problem.

Now you actually can set the Framerate Base with precision out to 6 places. (Go ahead and right now enter 1.00125 as the framerate base.)
Notice in this screen shot that blender knows that my custom frame rate is 23.97; yet it is still displaying that the framerate base is just 1.001.
blender's render dimensions settings

Copy the line below into the Python Console then press Enter you will see what the value really is. D.scenes['Scene'].render.fps_base

$\endgroup$
  • $\begingroup$ Awesome, now all of the work I put in setting up Blender to be a usable editor is not for nothing. Although I'd still like to figure out how to export using h264 with variable bit rate. $\endgroup$ – coffeeaddict May 28 '16 at 1:27
  • $\begingroup$ @coffeeaddict let me know if the frame rate did fix your audio out of length issue. $\endgroup$ – David May 28 '16 at 1:51
  • $\begingroup$ I think I have fixed it by changing the FPS denominator value to 1.001001 which results in a frame rate of 23.976 fps (the fps of my camera). I have four clips in the sequencer (all shot with same camera). 3 of the 4 clips are now perfectly in sync, but oddly one of them did not change. I will do some further testing but it seems to be an anomaly since there is another clip of almost the same length that is now in sync as well as the 2 others that are both longer clips. $\endgroup$ – coffeeaddict May 28 '16 at 2:55
  • 1
    $\begingroup$ Something is amiss. NTSC frame rates are 24000/1001, not that whackjob rate you have input. Codecs frequently encode a differing number of frames to audio length, so it is possible this might be what you are facing. Bottom line is that nutjob frame rates aren't the solution. $\endgroup$ – troy_s May 28 '16 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.