2
$\begingroup$

I'm trying to link an armature I made for a model to a different model (with a very similar shape), but when I try to link them together (ctrlp -> Set Parent to Bone) the model snaps upward. I thought this might be because the 3D cursor isn't set to the right place so I checked and gave it another try but that didn't seem to work either.

enter image description here

I'm hoping this image describes it well enough. The moment I select Set Parent to Bone, it immediately snaps up. If I could get help that would be really great, thanks!!

EDIT: thanks for the suggestions. i tried both resetting the armature to its original position and 'Set parent to -> Armature Deform -> With Automatic Weights/With Empty Groups' but the snapping still seems to be happening.

i've added the .blend file below if that helps. i apologise if it's a very noob-y issue as i'm quite new to blender and i've been asking a lot of novice questions.



thank you!

$\endgroup$
1
$\begingroup$

You have moved your armature up/down in pose mode. You can check this using tab, Ctrl+tab on your armature.
The position of your armature has to be the same in object/edit mode and pose mode, and matching your mesh, before you apply it.

To fix this, select all bones with A in pose mode, then you can reset position with alt+G, scale with alt+S and rotation with alt+R. This makes the pose back to "rest position" wich is the same as edit/object mode pose. Then you can move your armature (object mode) or your mesh to match them.

EDIT:
Your problem is that your mesh and armature are parented, but as objects. You can fix this problem adding an armature modifier to your mesh and selecting your armature as object. Be sure to check vertex groups (default) as they have been created earlier (and working well).
modifier

You can also fix the problem using the 1st part of this answer after selecting your mesh and Alt+P to clear parenting. Then you can make things cleaner.

$\endgroup$
1
$\begingroup$

You shouldn't be setting the parent to the bone. You should be setting "Set parent to -> Armature Deform -> With Automatic Weights" or "With Empty Groups" depending on your needs.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.