1
$\begingroup$

I am viewing a 3D scene using the viewport. This problem also appears when using the Render button. I am having black results for my Glass BSDF stones. When I zoom out, I get black results. On the contrary, when I zoom in, I get good results. How can I achieve good results in every case? Blender 2.77a

material rendering black

cycles material nodes

material rendering correctly

I include a short version error: https://dl.dropboxusercontent.com/u/3322974/BlackStones.blend

Hardware: Mac Pro 5,1; Memory 24gb; 2 processors 2,26 ghz; AMD Radeon HD 7950 3072 MB; OSX El Capitan 10.11.5; Rendering using CPU

$\endgroup$
  • $\begingroup$ Can you upload a .blend file? $\endgroup$ – Shady Puck May 26 '16 at 15:07
  • 1
    $\begingroup$ Try increasing the transparency bounces... possibly related: blender.stackexchange.com/questions/48226/… $\endgroup$ – cegaton May 26 '16 at 15:18
  • $\begingroup$ You have a link to download. This is a short version. $\endgroup$ – jagoji3d May 26 '16 at 16:03
  • 1
    $\begingroup$ I can't reproduce the error with the file you uploaded, it renders fine: i.stack.imgur.com/ra4pB.jpg $\endgroup$ – cegaton May 26 '16 at 16:22
  • 1
    $\begingroup$ @jagoji3d No, I stay away from Macs and Radeons... $\endgroup$ – cegaton May 27 '16 at 16:27
1
$\begingroup$

Your card is not fully supported by Blender.

From the Wiki:

Radeon HD 7000 series (southern islands) | Windows 7 x64 | Catalyst Beta 15.04 | Works (Not all features)

To confirm that this is the problem, disable GPU render and use CPU render, and the problem should go away. CPU will be MUCH slower, but it will support all features.

If the problem still exists with ONLY CPU rendering, then this is not the right answer.

$\endgroup$
  • $\begingroup$ The problems exits with only cpu rendering. Rendering with 2.77 (no 2.77a) is ok. $\endgroup$ – jagoji3d May 29 '16 at 8:47
  • $\begingroup$ Wow, yup. That's a straight-up bug. $\endgroup$ – Matt May 31 '16 at 13:18
0
$\begingroup$

Try increasing the Render Distance for your viewport. They might be black because they're being clipped by the far clipping plane.

Press n to open the settings for the viewport, and find the "distance" field. Increasing that might help.

If that works, you should also check the "Start" and "End" values on the Camera itself, because they are managed separately.

$\endgroup$
  • $\begingroup$ I suppose that clipping is for complete scene. I have increased my Viewport Clipping to: Start:1mm End 10 km with same results. $\endgroup$ – jagoji3d May 26 '16 at 16:01
0
$\begingroup$

This could also have happened, if you disabled "Camera" in the visibility settings of the gem object.

Look in the Object tab for the crystals, and make sure "Camera" is selected in the visibility section.

enter image description here

$\endgroup$
  • $\begingroup$ Camera is selected $\endgroup$ – jagoji3d May 26 '16 at 15:58
0
$\begingroup$

The problem seems to come from the sphere "DomeEsfera" that is emitting light from a voronoi texture that is not visible to the camera but is the only light in your scene.
voronoi object
You have to zoom out to see it and activate "camera" in the visibility of your object tab to see it. As it's the only light on glossy objects on 360°, you can easily see the black (no light). You have to add some other lights, or use a colorRamp to limit the black to mid-grey, or use a HDR image as background...

$\endgroup$
  • $\begingroup$ You have 3 more cameras without render problem. Try it. $\endgroup$ – jagoji3d May 27 '16 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.