0
$\begingroup$

Sometimes, when performing a cloth bake, certain parts of the cloth "collapse" inward very quickly before the other parts have deformed. The screenshot shows what happens.

Cloth bake screenshot

The top portion of the cloth has "collapsed" very quickly. The preset used for this was "Denim". Is there a certain cloth bake parameter(s) that could be tweaked to prevent this? I am using the latest version of Blender.

Result 2: Chaning self-collision parameters. No change:

Self-collision

Result 3: Greatly increasing the mass. The results are now much better. (The results seem to be the opposite of what I would expect. I would expect the issue above to happen if the mass was too high. However, the opposite effect seems to happen).

enter image description here

$\endgroup$
1
$\begingroup$

This was caused by numerous triangles which were not connected to each other on the head area of mesh. There were also duplicate vertices in the problematic area.

| improve this answer | |
$\endgroup$
0
$\begingroup$

This is probably because your Self Collision Distance (two down from the Self Collision checkbox) is set too high. The part that's collapsing probably thinks that it's already colliding with itself as soon as the sim starts. Which can cause some odd behavior.

Make both "Distance" settings small (under Cloth Collision and under Self Collision), and more-or-less the same.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ I tried what you said to no avail. I even disabled the self collision. The results were the same. However, I greatly increased the mass of the cloth, and the results are much better. (See above) $\endgroup$ – TTTTTTa May 25 '16 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.