1
$\begingroup$

At the moment I am trying to make a mustache because I thought a hairy ball was to simple. I created a model in a "mustache shape" and added the hair. Now I have the problem that I can't add any hair by using the "Add" brush. I tied to change different values a bit but nothing seams to make it work.

Because I probably explained it poorly here is a video of the problem: https://youtu.be/1DHYQZPMXbc

I hope I made the problem I am having clear and that someone can help me with it.

$\endgroup$
1
  • $\begingroup$ I checked your file and found nothing...You can add another particle system and work on it or start again. Your particle system seems broken. Can't help you more $\endgroup$
    – Bithur
    May 25, 2016 at 17:23

3 Answers 3

2
$\begingroup$

Click on "Free Edit" and change the "Emit From:" setting in the Emission panel from Volume to Faces.

$\endgroup$
2
  • $\begingroup$ Can you elaborate on why will Faces method of emitting particles allow adding new particles with Add brush as opposed to Volume method? Note also that pressing Free Edit button will erase all the particles changes done in Particle Edit mode $\endgroup$
    – Mr Zak
    Dec 10, 2017 at 18:01
  • $\begingroup$ The volume selection "emits hair particles from the volume of an enclosed mesh." OPs mesh isn't enclosed so there's no actual volume to emit from. I'm surprised that it emitted any hair at all. There were good mesh faces and that fixed the problem. The Free edit option was necessary and, given that no more hair was going to be added under the settings as they were, keeping the particle changes was pointless. $\endgroup$
    – d8sconz
    Dec 13, 2017 at 4:45
1
$\begingroup$

I can't see your baking settings in the video, but this behavior can be caused if your particles aren't baked, or if they are baked to a Disk Cache.

From the Manual:

Only Frames Baked to Memory are Editable!

If you cannot edit the particles, check that you are not baking to a Disk Cache.

To change this, uncheck "Disk Cache" in your cache settings.

enter image description here

$\endgroup$
1
  • 2
    $\begingroup$ I am working with a particle system without physics so I'm unable to use/see the cache settings. The main problem I have is that I can't use the add brush in the particle edit mode. When I try to add hair with this brush nothing happens/ it doesn't add hair. $\endgroup$ May 25, 2016 at 16:41
0
$\begingroup$

I had a similar problem. In my case, the solution was to select Particle in the Editing Type dropdown of the Tool Options.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.