8
$\begingroup$

So I have installed a fresh copy of Blender 2.69. I launch it. Open a new project. Hit the space bar and type Quick Smoke. I select Quick Smoke.

On load of the Quick Smoke the Domain for Smoke is Solid Black and will render only as solid black. I have not modified any other settings.

I tried a new file with Quick Fluid. I get a solid Grey/blue Domain and no render of the fluid. It seems that blender is not working properly.

Please advise.

Mind you I have Not change any settings and am loading Quick Smoke and Quick Fluid from a fresh start new session.

Thanks,

P.S. yes I did search and found 1 familiar topic however the answers provided were not correct for this issue.

$\endgroup$
  • 1
    $\begingroup$ Did you launch the animation (Alt+A) in order to compute a minimum of smoke simulation frames ? And, for fluid, did you click on the 'Bake' button in the Physics tab ?? $\endgroup$ – Polosson Dec 7 '13 at 0:14
  • 1
    $\begingroup$ I think everyone was quick to answer. I believe there is a bug in Blender 2.69. I have the same problem and it only occurs on my laptops which has integrated graphics cards. This does not happen on my desktop which has an nvidia card. I have seen way too many posts about this and unfortunately, everyone dismisses the posting user as "doing something wrong". My scenes are well lit and I have even opened other blend files from other users and they show up with the smoke domain as a black box. $\endgroup$ – user2093 Jan 7 '14 at 23:30
  • $\begingroup$ Could you attach a .blend in which this is occurring? Then we can determine whether this is a bug or a setting. $\endgroup$ – gandalf3 Jan 8 '14 at 0:20
  • $\begingroup$ The Correct Answer was that the Laptop was using a Intel Integrated Graphics Chip-set that currently bugs out when rendering in Blender 2.69. This is a Blender 2.69 Bug for that Chipset. $\endgroup$ – user1782 Jan 9 '14 at 15:46
  • 3
    $\begingroup$ I´m having the same problem with my notebook. It´s a bug with Intel integrated graphic cards. The workaround is: select DOMAIN object, go to physics tab, now check these boxes: 1) SMOKE ADAPTIVE DOMAIN , 2) SMOKE HIGH RESOLUTION . Black box gone. (Also make settings for Material & Texture). $\endgroup$ – user2411 Feb 9 '14 at 18:36
8
$\begingroup$

A general answer to this is because there are either no lights in your scene or you haven't computed the smoke simulation yet. To add a lamp to your scene, use ShiftA > Lamp and choose one. To simulate the smoke, you can just hit AltA or bake it to disk under Smoke Cache in the Physics panel (you must save the file first).

Also, the default Point lamp is a bit weak and might not illuminate the smoke properly depending on the angle viewed. A Hemi or Sun lamp should be sufficient for most tests.

Without any light

enter image description here

With a hemi lamp

enter image description here

$\endgroup$
3
$\begingroup$

This is because before render, you must launch animation (hit ALT A) in order to compute smoke simulation. When you play the animation, you'll see the smoke throwing up the cube.

Then, be sure there is some lights in your scene, and render!

Also, you need to assign the Smoke Domain a material with Volume shaders when rendering with Cycles.

$\endgroup$
  • $\begingroup$ The scene will still render as black before/after smoke is computed. $\endgroup$ – iKlsR Dec 7 '13 at 0:25
  • $\begingroup$ I'm pretty certain there is a point light that comes with the default cube and camera when you start a default new session. (not 100% still, coz it's been a long time I changed the default settings) $\endgroup$ – Polosson Dec 7 '13 at 0:34
  • $\begingroup$ Polosson, actually you are right. Using the default scene, the smoke needs to be computed first, but it will render black without any lamps. (my default scene doesn't have any lamps so I forgot abt that). $\endgroup$ – iKlsR Dec 7 '13 at 0:36
0
$\begingroup$

A computer with an integrated graphics chip (IGC) may lack the minimum requirements needed to render (display) objects correctly in the 3D viewport. The OpenGL minimum requirements for the current official release of Blender is OpenGLv.2.1. Some older model computers contain IGCs that are OpenGLv.2.0 or earlier version. To determine your computer's system OpenGL version go to the text editor inside of Blender. Select it from the bottom left corner of a port (window) where an icon with a drop down menu is located. Once you enter text editor, go to top menu and select Help > System Info. A file named system-info.txt will automatically be generated. Now, go to second icon with drop down menu. It is located to the right of the first icon you selected at the bottom menu. You will see the file "system-info.txt". Click it. Scroll down the contents of the file to the OpenGL section. Is you IGC's version 2.1 or newer? If not, this may likely be the cause of the black cube.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.