0
$\begingroup$

I checked pack all into .blend to send a friend the file. But when he opened it he couldn't load background image. How to pack everything into blend file so that will be possible?

$\endgroup$
  • 5
    $\begingroup$ When packing, you need to save the file after choosing the pack menu item. A quick way to verify everything's packed is to move the saved blend elsewhere and open it. $\endgroup$ – Italic_ May 24 '16 at 5:00
  • 1
    $\begingroup$ related: blender.stackexchange.com/questions/44225/… also make sure that the person opening the file enables Load UI read: blender.stackexchange.com/a/45027/1853 $\endgroup$ – cegaton May 24 '16 at 5:05
  • $\begingroup$ There appears to be a bug related to saving the directory path for environment images. I've never been able to get my default scene to remember where the environment textures are located. They always show up as magenta until I re-point the nodes to the correct path every time I load the default scene. Also, this happens often when I load any scene, but not always, it's random. Maybe the same troubled code is affecting you as well. $\endgroup$ – MarcClintDion Jul 7 '16 at 22:38
2
$\begingroup$

Unfortunately, there doesn't seem to be an easy way to see which image files are packed into a blend file, except to individually load every file into the UV editor, select the Image menu, and see if it offers the option to pack the file. If it doesn't then it's already packed. If it does then you should select that option, and when you've checked every file, save the blend file to finalize the procedure. You can then reload the same blend file and they should all be packed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.