2
$\begingroup$

Right, so I recorded a video, tracked it, set the ground planes etc. And made a cube. The cube renders, but its solid gray, and lighting effects just dont work. I am extremely novice to blender, so its probably just a stupid mistake. Essentially the cube appears a solid gray, green or whatever color I set it to on all sides when rendering, with no tone differences at all. Also, and this might be the problem, I have a cube on a ground layer set up like this:

This is what it looks like before and after render:

Also for additional Info, here are my settings:

My .blend: https://drive.google.com/file/d/0BzgDIjhDOu6EY2FOdzNSUVdrTjg/view?usp=sharing Thanks.

$\endgroup$
  • 3
    $\begingroup$ Please don't make the question dependent on downloading a file only. Please take the time to describe what you've done and add images that show your scene and settings. That way if the link to the file disappears, others can still learn from your question. $\endgroup$ – user1853 May 20 '16 at 4:02
  • $\begingroup$ ^Alright thanks, I'll keep that in mind for future questions. $\endgroup$ – Josh Silveous May 20 '16 at 10:47
  • $\begingroup$ @JoshSilveous It would be useful if you could make the changes cegaton suggested this time. The reason for this is that if people find this question via google they will be able to understand whether they are having a similar issue to yours and whether the answer below will be relevant. $\endgroup$ – Ray Mairlot May 20 '16 at 15:52
1
$\begingroup$

You only have layer one enabled for rendering, and your lamp and plane are on layer 6. To fix this, go to the render layers tab, and select both layers while holding Shift that you want to render together, and you shouldn't have any problems.

enter image description here

| improve this answer | |
$\endgroup$
-1
$\begingroup$

well the cube and plane don't have a material also just changing the it from blender render to cycles render makes the shading right this means you have probably ticked some boxes unknowingly can't figure out which ones but just changing it to cycles engine worked. enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.