28
$\begingroup$

I have added some textures to objects in blender but the textures don't show up until I render the file. it can be difficult to know what the objects look like without rendering it. is there a way to have textures show in the editor even if they are at a lower res?

In editor:

enter image description here

Rendered:

enter image description here

$\endgroup$
28
$\begingroup$

Blender internal:

Try setting the viewport shading to Texture (AltZ):

enter image description here

Note that this only works when the object's UV map has the appropriate texture displayed in the UV/image editor: (see this post for more information)

enter image description here

To display the textures used in the material of the object regardless of the texture (or lack of texture) displayed in the UV image editor, enable GLSL in 3D view > Properties region (N) > Shading and set the viewport shading to Texture:

enter image description here

Cycles:

You need a material to display textures in the viewport in cycles.

Set the viewport shading to Texture or Material.

Texture displays the texture of the last selected image texture node:

enter image description here

Material tries to approximate the result of the shader nodes, so if you have two combined textures:

enter image description here

$\endgroup$
  • $\begingroup$ I can't find that last option could you post a larger screenshot. also I am using blender 2.66a if it matters $\endgroup$ – Qwertie Dec 4 '13 at 8:13
  • $\begingroup$ @qwertyk31 In blender 2.66a it's under the Display panel IIRC. (Assuming you mean GLSL) $\endgroup$ – gandalf3 Dec 4 '13 at 8:14
  • $\begingroup$ yea I did mean GLSL but I will just update blender I don't know why the Ubuntu software center one is out of date $\endgroup$ – Qwertie Dec 4 '13 at 8:25
  • $\begingroup$ I have enabled GLSL but still no textures. $\endgroup$ – Qwertie Dec 6 '13 at 9:55
  • 1
    $\begingroup$ @gandalf3 I'm having real trouble in making this work in Cycles. I think I activated all the options you've mentioned.... Is anyone aware of known issues to make the textures work in realtime in the viewport? i can only see them in "rendered" shading mode. please help! $\endgroup$ – invicente Dec 12 '14 at 14:45
3
$\begingroup$

The object with the texture needs to have its Maximum Draw Type set to Textured. This setting is in Properties Editor > Object settings then the Display section. This applies to Cycles and Blender Internal.

$\endgroup$
  • $\begingroup$ That is the default and seem not to work. $\endgroup$ – clankill3r Feb 1 '16 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.