5
$\begingroup$

It should be noted that this question poses a similar issue to some other questions on SE, but (the ones that I saw) were caused by massively large scaling factors, which (as far as I can tell) isn't the source of this issue.

I'm trying to import this svg into blender so that I can extrude it afterwards. All I can manage to get is this result:

Broken render

I'm very new to blender, so I don't know what the issue could be. All I did to get this was create a new scene, import the svg, and zoom/move the view to make it visible.

As well, I have uploaded (and publicly shared, of course) the .blend file for those who are interested.

$\endgroup$
  • $\begingroup$ I can't access the blend file for some reasons, but i can see there are intersections/overlapping from the screenshot, in blender curves perform some Boolean operation when they intersect/overlap. $\endgroup$ – user2816 May 17 '16 at 23:11
  • $\begingroup$ Oops... I changed the sharing permissions. $\endgroup$ – Potassium Ion May 18 '16 at 1:04
3
$\begingroup$

Your object is causing trouble because it's a self intersecting path and has overlapping parts that cause Blender to be unable to cleanly extrude it.

Answering your question in the comment above yes, you can keep it as a single object and fix the extrusion, but it will require some editing in an external program.

Luckily you can do it for free with Inkscape. Open your file in Inkscape and combine both shapes together into a single path using a Boolean operation with either

  • Select object and press Ctrl + + or,
  • Select object and go to the menu Path > Combine

Before and After path boolean Before (left) and after (right) path boolean

Save your file and re-import into Blender and extrude at will

Extrude SVG

$\endgroup$
  • $\begingroup$ Great solution. Side note: what did you do to set that bevel? The option I tried didn't do the bevel correctly? $\endgroup$ – Potassium Ion May 19 '16 at 1:00
  • $\begingroup$ You can find the bevel option under the Properties Window > Object Data Tab > Geometry > Bevel, and add a small value there. If you want no shape distortion be sure to add the same value as negative to the Offset parameter so as not to make your shapes "fat" or bold. If for example you add say 0.01 to Bevel also add -0.01 (negative) to the offset $\endgroup$ – Duarte Farrajota Ramos May 19 '16 at 1:16
4
$\begingroup$

You have overlapping curves.

Your choices vary depending on what the element is supposed to look like:

  • Edit your SVG file with a vector graphics editing program and make the different elements into separate paths.

  • On the imported SVG separate the elements: Select one of the control points on the curve and press CtrlL to select the linked segment:

enter image description here

Then press P to separate it into a new object.

enter image description here

$\endgroup$
  • $\begingroup$ Is there any fix that will allow me to have it as one object? Or will I be able to join them back together after extruding? I don't exactly know if I will need for it to be one object for my case, but I will try it later on tonight and see what happens. $\endgroup$ – Potassium Ion May 18 '16 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.