I want to change the distribution of objects in a particle system between two frames. Though there is an option to keyframe I cannot get it to work.


Am I doing something wrong? Or is there a bug? I am using Blender v2.76.

Example file:
In frame 1 I want to have 20 times as many icosphere as cubes.
In frame 2 I want to have 20 times as many cubes as icosphere.

  • $\begingroup$ So is your question only about 2 frames? What is the visible lifetime of the particles from the viewpoint of Viewer of your work? The larger picture. Please explain the lifetime. A screen capture of the particle system indicating lifetime might help with a new question. $\endgroup$ – atomicbezierslinger May 15 '16 at 17:01
  • $\begingroup$ @atomicbezierslinger In reality it's 5 frames. The particles only remain for one frame each. The following frame I want different particles (my motivation for keyframing the distribution). Because it's only 5 frames I solved my problem by creating 5 different particle systems with each their only distributions. $\endgroup$ – theHacker May 16 '16 at 14:34
  • $\begingroup$ blender.stackexchange.com/questions/46076/… $\endgroup$ – atomicbezierslinger May 16 '16 at 15:08

You have keyframed the checkbox that enables or disables 'Use Count', not the 'Count' values themselves, which are shown below the large yellow box in your screenshot.

However, trying to keyframe the actual 'Count' value displays an error message, which indicates that these values probably can't be animated.

I would suggest posting another question on this site asking specifically about how to get different amounts of particles to appear.

  • $\begingroup$ Keyframing the checkbox in addition was my second try as I noticed the keyframe of the list does not work. $\endgroup$ – theHacker May 16 '16 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.