1
$\begingroup$

I'm having a lot of trouble understanding how Blender handles textures. It seems to require linking them in multiple places. Look at the following screenshot:

screenshot

So here I have a mesh with a cloud texture (texture.002) and a texture in the UV window (untitled.png, saved to disk, which my fumbling suggests matters). Neither is displaying on my model. Untitled is not showing up in the texture list. And texture paint is giving me a warning that there is no texture. (FWIW, textured display in object mode gives me yet another appearance, which appears to be white.)

I have specific issues-- visualizing my UV mapping, getting a blank texture assigned for AO baking so I stop getting the no object or image error-- but I'm hoping for a more general understanding of these issues.

$\endgroup$
  • $\begingroup$ I think you need to understand first some important basics. There are tons of good and comprehensible videos out there. Just try to follow them and you learn much more than people can teach you in a few lines on stack exchange. $\endgroup$ – metaphor_set May 14 '16 at 19:01
  • $\begingroup$ I do need to understand some important basics. The tutorials I've seen all focus on practical issues, and as I follow them, it works out, but when I try to put it together, I don't understand what's going on. Maybe I'm not looking at the right tutorials. Can you suggest any that would help me understand the various ways in which Blender treats textures? $\endgroup$ – Nathan May 14 '16 at 19:15
  • $\begingroup$ Is your model unwrapped already? If not that's the starting point. $\endgroup$ – metaphor_set May 14 '16 at 19:46
  • $\begingroup$ It is-- you should be able to see the faint silhouette of the UV map on that screenshot. $\endgroup$ – Nathan May 14 '16 at 19:57
0
$\begingroup$

There are several different concepts shown in your screenshot.

  1. "Untitled" in the UV / Image Editor is not a texture; it is image loaded into editor (in this case, it's image generated by Blender, but it could be any image). It won't be shown in the texture list as long as it is not assigned to any texture slot.
  2. Texture Paint mode shows "Missing Data" error because you have only procedural texture applied to your mesh in texture settings (of type Clouds); procedural textures can't be paint on. Hence Blender suggests you to create new image paint slot, which will be used for painting on.
  3. If it's inconvinient to create new image to paint on (e.g. you have already one and would like to paint on that), you can use it instead.
    In order to do that, create (or choose from list) texture slot in texture settings of Image or Movie type and link desired image to it (i.e. if it's desired to paint on "Untitled" image you'll select it on this step).
  4. If Texture Paint for some reason still haven't found accessible paint slot, you can refresh settings of Texture Paint panel. This can be done by opening Slots tab, and choosing appropriate material from list once more (or changing any texture options, like selecting image linked to texture once more).

enter image description here

Assigning a texture in manual.

This is for Blender Internal and it's a bit different in Cycles engine.

$\endgroup$
2
$\begingroup$

In order to paint on a texture, the texture must be of type "Image or Movie":

enter image description here

$\endgroup$
  • $\begingroup$ That's good to know, but there must be other issues as well. !screenshot After using + to create a new texture and assigning it that type, texture paint is still showing warnings and pink. $\endgroup$ – Nathan May 14 '16 at 20:50
  • $\begingroup$ @Nathan You also must select or generate an image on which to paint. Click the New button visible in your screenshot to generate a blank image $\endgroup$ – gandalf3 May 14 '16 at 20:54
  • $\begingroup$ Thank you. I was failing to see the distinction between an image and a texture. I should now be able to get a little further in my experimentation and googling. $\endgroup$ – Nathan May 14 '16 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.